PickerInputTwoPoints Class

The PickerInputTwoPoints class represents a pick of two points in a view. Used for values asked by UI.Picker.PickTwoPoints(string FirstPrompt, string SecondPrompt, out Point FirstPickedPoint, out Point SecondPickedPoint, out ViewBase PickedView).
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public class PickerInputTwoPoints : PickerInputPointsWithinAView

The PickerInputTwoPoints type exposes the following members.

Constructors
  NameDescription
Public methodPickerInputTwoPoints
Creates a new PickerInputTwoPoints instance with two points selected in a view.
Top
Properties
  NameDescription
Public propertyFirstPickedPoint
The first picked point in the view coordinates.
Public propertySecondPickedPoint
The second picked point in the view coordinates.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PickerInputPointsWithinAViewIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next