DrawingEnumerator Class

The DrawingEnumerator class provides the means to iterate through drawing instances. Drawing enumerators are generated by the drawing handler.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public sealed class DrawingEnumerator : DrawingEnumeratorBase

The DrawingEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Gets the current drawing.
Top
Methods
  NameDescription
Top
Fields
  NameDescription
Top
Examples
using Tekla.Structures.Drawing;

public class Example
{
       public void Example1()
       {
           DrawingHandler DrawingHandler = new DrawingHandler();

           // Loop through all available drawings and delete all GA drawings.
           DrawingEnumerator AllDrawings = DrawingHandler.GetDrawings();

           while(AllDrawings.MoveNext())
           {
               Drawing CurrentDrawing = AllDrawings.Current as GADrawing;
               if(CurrentDrawing != null)
               {
                   CurrentDrawing.Delete();
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next