CatalogHandlerImportBoltItems Method

Imports bolt items and their assembly information (*.bass) from folder to bolt assembly catalog and bolt catalog. Import overrides the existing bolts in the catalog without any warnings.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool ImportBoltItems(
	string path
)

Parameters

path
Type: SystemString
The path to be used for import.

Return Value

Type: Boolean
true if successful.
Examples
using System;
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           if (new CatalogHandler().ImportBoltItems(System.IO.Path.GetTempPath()))
               Console.WriteLine("Bolts and bolt assemblies imported successfully to catalog.");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next