ConnectionStatusEnum Enumeration

The status type defines what the status of a connection or a detail is. In the model the color of the symbol (green, yellow, red) indicates the status.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public enum ConnectionStatusEnum
Members
  Member nameValueDescription
STATUS_UNKNOWN0 The status is unknown.
STATUS_OK1 The status is ok and the symbol color is green.
STATUS_WARNING2 The status indicates a warning and the symbol color is yellow.
STATUS_ERROR3 The status indicates an error and the symbol color is red.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next