DrawingHandlerPrintDrawing Method (Drawing, PrintAttributes, String)

Prints the drawing to file using the given printer instance. NOTE! The drawing cannot be active, otherwise printing fails.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public bool PrintDrawing(
	Drawing drawing,
	PrintAttributes printAttributes,
	string fileName
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing to be printed.
printAttributes
Type: Tekla.Structures.DrawingPrintAttributes
The print attributes for the print job.
fileName
Type: SystemString
The name of the output file.

Return Value

Type: Boolean
True on success, false if printing fails.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next