TemplateInfo Class

The TemplateInfo class holds template information.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class TemplateInfo : GenericAttributesBase

The TemplateInfo type exposes the following members.

Constructors
  NameDescription
Public methodTemplateInfo
Creates a new template info instance.
Public methodTemplateInfo(String)
Creates a new template info instance with the given template file name.
Top
Properties
  NameDescription
Public propertyName
Gets or sets the name of the template file. E.g. "revision".
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
Fields
  NameDescription
Public fieldStatic memberDefault
The default template information.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next