ModelObjectSetUserProperties Method

Sets multiple properties for the model object.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public bool SetUserProperties(
	List<string> stringPropertyNames,
	List<string> stringValues,
	List<string> doublePropertyNames,
	List<double> doubleValues,
	List<string> intPropertyNames,
	List<int> intValues
)

Parameters

stringPropertyNames
Type: System.Collections.GenericListString
The names of the string properties to be set.
stringValues
Type: System.Collections.GenericListString
The new values for the string properties.
doublePropertyNames
Type: System.Collections.GenericListString
The names of the double properties to be set.
doubleValues
Type: System.Collections.GenericListDouble
The new values for the double properties.
intPropertyNames
Type: System.Collections.GenericListString
The names of the int properties to be set.
intValues
Type: System.Collections.GenericListInt32
The new values for the int properties.

Return Value

Type: Boolean
True if the property was set successfully.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next