UserPropertyOption Class

The UserPropertyOption class contains the properties of a user property value option.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsUserPropertyOption

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public sealed class UserPropertyOption

The UserPropertyOption type exposes the following members.

Constructors
  NameDescription
Public methodUserPropertyOption
Initializes a new instance of the UserPropertyOption class
Top
Properties
  NameDescription
Public propertyDoubleValue
The double value.
Public propertyIntValue
The integer value.
Public propertyOptionLabel
The option name.
Public propertyOptionLabelTranslated
The translated option name.
Public propertyStringValue
The string value.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next