AnalysisObjectSelectorSetSelectedObjects Method

Set analysis objects as selected in model views.

Namespace:  Tekla.Structures.Analysis.UI
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public int SetSelectedObjects(
	List<AnalysisObject> analysisObjects,
	bool append
)

Parameters

analysisObjects
Type: System.Collections.GenericListAnalysisObject
The analysis objects.
append
Type: SystemBoolean
If true, objects are added to currently selected. If false, current selection is cleared.

Return Value

Type: Int32
The count of objects selected.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next