PositionTypeAttribute Class

The PositionTypeAttribute class is used for storing the position type of the connection. Based on the type the system will then position the connection in the creation. The attribute is initialized from the custom attribute [PositionType(PositionTypeEnum.COLLISION_PLANE)] in the connection source.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsPositionTypeAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class PositionTypeAttribute : Attribute

The PositionTypeAttribute type exposes the following members.

Constructors
  NameDescription
Public methodPositionTypeAttribute(Int32)
The custom attribute [PositionType()] uses this to store the position type to the system. This is not to be used by itself.
Public methodPositionTypeAttribute(PositionTypeEnum)
The custom attribute [PositionType()] uses this to store the position type to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
The custom attribute [PositionType()] uses this to store the position type to the system. This is not to be used by itself.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next