WeldMarkSeamVisibilityAttributes Class

The SeamVisibilityAttributes class is the attributes class for the weld seam visibility.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingGenericAttributesBase
    Tekla.Structures.DrawingWeldMarkSeamVisibilityAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class SeamVisibilityAttributes : GenericAttributesBase

The WeldMarkSeamVisibilityAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyShowAngle
Gets or sets a value indicating whether the seam angle is visible.
Public propertyShowContour
Gets or sets a value indicating whether the seam contour is visible.
Public propertyShowEffectiveThroat
Gets or sets a value indicating whether the seam effective throat is visible.
Public propertyShowFinish
Gets or sets a value indicating whether the seam finish is visible.
Public propertyShowLength
Gets or sets a value indicating whether the seam length is visible.
Public propertyShowPitch
Gets or sets a value indicating whether the seam pitch is visible.
Public propertyShowPrefix
Gets or sets a value indicating whether the seam prefix is visible.
Public propertyShowRootOpening
Gets or sets a value indicating whether the seam root opening is visible.
Public propertyShowSize
Gets or sets a value indicating whether the seam size is visible.
Public propertyShowType
Gets or sets a value indicating whether the seam type is visible.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next