PhaseCollection Class

The PhaseCollection class handles the collection of the model phases.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelPhaseCollection

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class PhaseCollection : ICollection, 
	IEnumerable

The PhaseCollection type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of elements contained in the ICollection.
Public propertyIsSynchronized
Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public propertySyncRoot
Gets an object that can be used to synchronize access to the ICollection.
Top
Methods
  NameDescription
Public methodCopyTo
Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public methodGetEnumerator
Returns an enumerator that iterates through a collection.
Top
Examples
The following example gets the phases of the model and shows the values of the PhaseName and PhaseNumber properties in a message dialog:
using Tekla.Structures.Model;
using System.Windows.Forms;

public class Example
{
       public void Example1()
       {
           Model CurrentModel = new Model();
           PhaseCollection PhaseCollection = CurrentModel.GetPhases();

           if (CurrentModel.GetConnectionStatus())
           {
               foreach(Phase p in PhaseCollection)
               {
                    MessageBox.Show("Name = " + p.PhaseName + ", number = " + p.PhaseNumber);
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next