Grid Class

The Grid class defines a user defined (possibly magnetic) set of planes helping in modeling work. A grid has grid plane instances as children.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Grid : GridBase

The Grid type exposes the following members.

Constructors
  NameDescription
Public methodGrid
Creates a new grid instance.

The default values are as follows:

  • Name = "Grid";
  • CoordinateX = "0.00 4*3000.00";
  • CoordinateY = "0.00 5*6000.00";
  • CoordinateZ = "0.00 6000.00 8000.00 9000.00";
  • LabelX = "A B C D E";
  • LabelY = "1 2 3 4 5 6";
  • LabelZ = "+0 +6000 +8000 +9000";
  • ExtensionLeftX = 2000.0;
  • ExtensionLeftY = 2000.0;
  • ExtensionLeftZ = 2000.0;
  • ExtensionRightX = 2000.0;
  • ExtensionRightY = 2000.0;
  • ExtensionRightZ = 2000.0;
  • IsMagnetic = false;
Top
Properties
  NameDescription
Public propertyColor
Gets or sets the color of the grid.
Public propertyCoordinateX
The coordinates for the X-axis.
Public propertyCoordinateY
The coordinates for the Y-axis.
Public propertyCoordinateZ
The coordinates for the Z-axis.
Public propertyExtensionForMagneticArea Obsolete.
The extension for the magnetic area.
Public propertyExtensionLeftX
The extension to the left X-axis.
Public propertyExtensionLeftY
The extension to the left Y-axis.
Public propertyExtensionLeftZ
The extension to the left Z-axis.
Public propertyExtensionRightX
The extension to the right X-axis.
Public propertyExtensionRightY
The extension to the right Y-axis.
Public propertyExtensionRightZ
The extension to the right Z-axis.
Public propertyLabelX
The labels for the X-axis.
Public propertyLabelY
The labels for the Y-axis.
Public propertyLabelZ
The labels for the Z-axis.
Top
Methods
  NameDescription
Top
Examples
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           Grid Grid = new Grid();

           Grid.IsMagnetic = true;

           bool Result = false;
           Result = Grid.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next