ViewViewShorteningAttributes Constructor (Boolean, Boolean, Double, Double, ViewShorteningCutPartType)

Creates a new view shortening attributes instance with the given parameters.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public ViewShorteningAttributes(
	bool CutParts,
	bool CutSkewParts,
	double MinimumLength,
	double Offset,
	ViewShorteningCutPartType CutPartType = ViewShorteningCutPartType.BothDirections
)

Parameters

CutParts
Type: SystemBoolean
A value indicating whether cut parts are enabled.
CutSkewParts
Type: SystemBoolean
A value indicating whether cut skewed parts are enabled.
MinimumLength
Type: SystemDouble
The minimum cut part length.
Offset
Type: SystemDouble
The space between the cut parts.
CutPartType (Optional)
Type: Tekla.Structures.DrawingViewShorteningCutPartType
The optional cut part direction type.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next