AnalysisModel Class

The AnalysisModel class contains information related to analysis models.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisModel : AnalysisObject

The AnalysisModel type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisModel
Initializes a new instance of the AnalysisModel class.
Top
Properties
  NameDescription
Public propertyAnalysisConnectivityRules
Gets or sets the analysis model connectivity rules.
Public propertyAnalysisEngine
Gets or sets the analysis engine of the analysis model.
Public propertyAnalysisLoadCombinations
Gets the analysis load combinations of the analysis model.
Public propertyAnalysisLoadGroups
Gets the analysis load groups of the analysis model.
Public propertyAnalysisMethod
Gets or sets the analysis method of the analysis model.
Public propertyAnalysisModelDesignProperties
Gets or sets the analysis model design properties.
Public propertyAnalysisModelJobProperties
Gets or sets the analysis model job properties.
Public propertyAnalysisModelModalAnalysisProperties
Gets or sets the analysis model modal analysis properties.
Public propertyAnalysisModelOutputProperties
Gets or sets the analysis model output properties.
Public propertyAnalysisModelSeismicProperties
Gets or sets the analysis model seismic properties.
Public propertyAnalysisModelSpectrumProperties
Gets or sets the analysis model spectrum properties
Public propertyAnalysisNodeLinks
Gets the analysis node links of the analysis model.
Public propertyAnalysisNodes
Gets the analysis nodes of the analysis model.
Public propertyAnalysisParts
Gets the analysis parts of the analysis model.
Public propertyAnalysisRigidDiaphragms
Gets the analysis rigid diaphragms of the analysis model.
Public propertyAutodetectSecondaries
Gets or sets a value indicating whether bracing members are detected automatically.
Public propertyBracingFilterName
Gets or sets the bracing filter name.
Public propertyConstructionMethod
Gets or sets the construction method of the analysis model.
Public propertyFilterName
Gets or sets the filter name of the analysis model.
Public propertyIncludeImperfections
Gets or sets a value indicating whether imperfections are to be included.
Public propertyMemberAxislocation
Gets or sets the axis location of the members.
Public propertyMemberEndReleaseMethodByJoint
Gets or sets a value indicating whether the end releases are set by joint properties.
Public propertyModelUpdateModificationIdentifier
Gets or sets the identifier of the model update modification.
Public propertyNodePositionTolerance
Gets or sets the node position tolerance of the analysis model.
Public propertyNumberOfIterations
Gets or sets the number of iterations of the analysis model.
Public propertyPhysicalFreezed
Gets or sets a value indicating whether the physical objects are frozen.
Public propertyPhysicalFrozen
Gets or sets a value indicating whether the physical objects are frozen.
Public propertyRelativeAccuracy
Gets or sets the relative accuracy of the analysis model.
Public propertyResultsFreezed
Gets or sets a value indicating whether the results are frozen.
Public propertyResultsFrozen
Gets or sets a value indicating whether the results are frozen.
Public propertyResultsModificationIdentifier
Gets or sets the results modification identifier.
Public propertyResultsTime
Gets or sets the results time.
Public propertySecondaryFilterName
Gets or sets the bracing filter name.
Public propertySecondaryKeepAxis
Gets or sets the secondary keep axis settings. Not used, bracing/secondary members always have KEEP_AXIS_NO initially.
Public propertySecondaryMemberFilterName
Gets or sets the secondary member filter name.
Public propertySnapDistance
Gets or sets the snap distance of the analysis model.
Public propertyUseModelMerge
Gets or sets a value indicating whether model merge is used.
Public propertyUseTrueCurvedMembers
Gets or sets a value indicating whether members are true curved.
Public propertyUseTwinProfiles
Gets or sets a value indicating whether twin profiles are used.
Top
Methods
  NameDescription
Public methodDelete
Deletes an analysis model. The AnalysisModelName has to be set.
Public methodGetIssues
Get analysis model issues.
Public methodInsert
Inserts a new analysis model into the Tekla Structures model. The AnalysisModelName has to be set.
Public methodModify
Modifies an analysis model. The AnalysisModelName has to be set.
Public methodSelect
Selects an analysis model. Updates the model. The AnalysisModelName or ID has to be set.
(Overrides AnalysisObjectSelect.)
Public methodSelect(Boolean)
Selects an analysis model. The AnalysisModelName or ID has to be set.
Top
Fields
  NameDescription
Public fieldStatic memberPART_DEFAULTS_MODEL_NAME
The analysis model name for default analysis properties of a part.
Top
Examples
using Tekla.Structures.Analysis;

public class Class
{
    public void Example()
    {
        Analysis Analysis = new Analysis();

        AnalysisObjectSelector AnalysisObjectSelector = Analysis.GetAnalysisObjectSelector();

        AnalysisObjectEnumerator AnalysisObjectEnumerator = AnalysisObjectSelector.GetAllObjectsWithType(AnalysisObject.AnalysisObjectEnum.ANALYSIS_MODEL, "");

        while(AnalysisObjectEnumerator.MoveNext())
        {
            AnalysisModel AnalysisModel = AnalysisObjectEnumerator.Current as AnalysisModel;

            if(AnalysisModel == null) continue;
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next