ProfileItemParameterParameterUnitTypeEnum Enumeration

Defines the different unit types of the profile item parameter.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public enum ParameterUnitTypeEnum
Members
  Member nameValueDescription
INPUT_BOOLEAN-3 The input boolean.
INPUT_INTEGER-2 The input integer.
INPUT_STRING-1 The input string.
INPUT_NONE0 The input none.
INPUT_RATIO_UNIT1 The input ratio unit.
INPUT_STRAIN_UNIT2 The input strain unit.
INPUT_ANGLE_UNIT5 The input angle unit.
OUTPUT_ANGLE_UNIT6 The output angle unit.
INPUT_SECTION_ANGLE_UNIT7 The input section angle unit.
INPUT_LENGTH_UNIT10 The input length unit.
OUTPUT_LENGTH_UNIT11 The output length unit.
INPUT_DEFORMATION_UNIT12 The input deformation unit.
OUTPUT_DEFORMATION_UNIT13 The output deformation unit.
INPUT_DIMENSION_UNIT14 The input dimension unit.
INPUT_RADIUSOFINERTIA_UNIT16 The input radius of inertia unit.
INPUT_AREA_UNIT20 The input area unit.
OUTPUT_REINFAREA_UNIT21 The output reinforced area unit.
OUTPUT_TRANSVREINF_UNIT22 The output transverse reinforcement unit.
INPUT_AREAPERLENGTH_UNIT23 The input area per length unit.
OUTPUT_VOLUME_UNIT30 The output volume unit.
INPUT_SECTIONMODULUS_UNIT31 The input section modulus unit.
INPUT_VOLUME_UNIT32 The input volume unit.
INPUT_MOMENTOFINERTIA_UNIT40 The input moment of inertia unit.
INPUT_TORSIONCONSTANT_UNIT41 The input torsion constant unit.
INPUT_WARPINGCONSTANT_UNIT60 The input warping constant unit.
INPUT_FORCE_UNIT100 The input force unit.
OUTPUT_FORCE_UNIT101 The output force unit.
INPUT_WEIGHT_UNIT102 The input weight unit.
OUTPUT_WEIGHT_UNIT103 The output weight unit.
INPUT_DISTRIBLOAD_UNIT110 The input distributed load unit.
OUTPUT_DISTRIBLOAD_UNIT111 The output distributed load unit.
INPUT_SPRINGCONSTANT_UNIT112 The input spring constant unit.
OUTPUT_MASSPERLENGTH_UNIT113 The output mass per length unit.
INPUT_SURFACELOAD_UNIT120 The input surface load unit.
OUTPUT_SURFACELOAD_UNIT121 The output surface load unit.
INPUT_STRENGTH_UNIT122 The input strength unit.
OUTPUT_STRESS_UNIT123 The output stress unit.
INPUT_MODULUS_UNIT124 The input modulus unit.
INPUT_DENSITY_UNIT131 The input density unit.
INPUT_MOMENT_UNIT200 The input moment unit.
OUTPUT_MOMENT_UNIT201 The output moment unit.
INPUT_DISTRIBMOMENT_UNIT205 The input distributed moment unit.
INPUT_ROTSPRINGCONST_UNIT210 The input rotation spring constant unit.
INPUT_TEMPERATURE_UNIT300 The input temperature unit.
OUTPUT_TEMPERATURE_UNIT301 The output temperature unit.
INPUT_THERMDILATCOEFF_UNIT310 The input thermal dilatation coefficient unit.
INPUT_FACTOR_UNIT400 The input factor unit.
INPUT_DATE_UNIT401 The input date unit.
INPUT_DATE_TIME_MIN_UNIT402 The input date time minutes unit.
INPUT_DATE_TIME_SEC_UNIT403 The input date time seconds unit.
INPUT_LENGTH_FRACTIONAL_IMPERIAL1005 The input length, fractional imperial.
INPUT_DEFORMATION_FRACTIONAL_IMPERIAL1305 The input deformation, fractional imperial.
INPUT_DIMENSION_FRACTIONAL_IMPERIAL1405 The input dimension, fractional imperial.
INPUT_RADIUSOFINERTIA_FRACTIONAL_IMPERIAL1605 The radius of inertia, fractional imperial.
OUTPUT_LENGTH_FRACTIONAL_IMPERIAL1105 The output length, fractional imperial.
OUTPUT_DEFORMATION_FRACTIONAL_IMPERIAL1305 The output deformation, fractional imperial.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next