EdgeChamfer Class

The EdgeChamfer class defines how the part edge is chamfered.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class EdgeChamfer : Boolean

The EdgeChamfer type exposes the following members.

Constructors
  NameDescription
Public methodEdgeChamfer
Initializes a new instance of the EdgeChamfer class with empty attributes.
Public methodEdgeChamfer(Point, Point)
Initializes a new instance of the EdgeChamfer class.
Top
Properties
  NameDescription
Public propertyChamfer
The chamfer values for the EdgeChamfer.
Public propertyFirstBevelDimension
The bevel dimension if the first end is bevelled.
Public propertyFirstChamferEndType
The ChamferEndTypeEnum of the first end.
Public propertyFirstEnd
The start point of the EdgeChamfer.
Public propertyName
The name of the EdgeChamfer instance.
Public propertySecondBevelDimension
The bevel dimension if the second end is bevelled.
Public propertySecondChamferEndType
The ChamferEndTypeEnum of the second end.
Public propertySecondEnd
The end point of the EdgeChamfer.
Top
Methods
  NameDescription
Public methodDelete
Deletes the edge chamfer instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the edge chamfer into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing edge chamfer in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects an edge chamfer from the model database. The edge chamfer ID must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point Point = new Point(0, 0, 0);
           Point Point2 = new Point(1000, 0, 0);

           Beam Beam = new Beam();
           Beam.StartPoint = Point;
           Beam.EndPoint = Point2;
           Beam.Profile.ProfileString = "400*400";
           Beam.Finish = "PAINT";
           Beam.Insert();

           EdgeChamfer EdgeChamfer = new EdgeChamfer(new Point(0, -100, 0), new Point(0, 200, 0));
           EdgeChamfer.FirstChamferEndType = EdgeChamfer.ChamferEndTypeEnum.BEVELLED;
           EdgeChamfer.FirstBevelDimension = 50;
           EdgeChamfer.Chamfer.X = 20;
           EdgeChamfer.Chamfer.Y = 20;
           EdgeChamfer.Father = Beam;
           EdgeChamfer.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next