LineTypeAttributes Class

The LineTypeAttributes class contains basic attributes for lines.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LineTypeAttributes : GenericAttributesBase

The LineTypeAttributes type exposes the following members.

Constructors
  NameDescription
Public methodLineTypeAttributes
Creates a new line type attributes instance.
Public methodLineTypeAttributes(LineTypes, DrawingColors)
Creates a new line type attributes instance with the given line type and color.
Top
Properties
  NameDescription
Public propertyColor
The color of the line (see DrawingColors for options).
Public propertyType
The type of the line (see LineTypes for options).
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next