BoltBoltAttributes Class

The BoltAttributes class is the attributes class for the bolt.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingBoltBoltAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class BoltAttributes : AttributesBase

The BoltBoltAttributes type exposes the following members.

Constructors
  NameDescription
Public methodBoltBoltAttributes
Creates a new default bolt attributes instance that loads standard attributes.
Public methodBoltBoltAttributes(String)
Creates a new bolt attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyColor
The color of the bolt.
Public propertyCustomPresentation
Custom presentation GUID to be applied to the bolt
Public propertyRepresentation
The representation type of the bolt.
Public propertySymbolContainsAxis
True if the bolt symbol contains an axis.
Public propertySymbolContainsHole
True if the bolt symbol contains a hole.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next