DistanceUseFractionalFormat Property

Gets or sets a boolean value indicating whether to use the fractional format for US imperial units.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
public static bool UseFractionalFormat { get; set; }

Property Value

Type: Boolean
Indicates whether to use the fractional format for US imperial units.
Examples
using Tekla.Structures.Datatype;
using System.Globalization;

public class Example
{
       public void Example1()
       {
           // UseFractionalFormat controls whether the feet and inches are formatted using the fractional representation.
           Distance.UseFractionalFormat = true;

           // For this demonstration, we'll format 300.2 millimeters.
           Distance distance = new Distance(300.2);
           string formattedString = distance.ToString("0.00", CultureInfo.InvariantCulture, Distance.UnitType.Inch);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next