UnitAttributes Class

The UnitAttributes class handles attributes related to units and formatting of values.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class UnitAttributes : GenericAttributesBase, 
	ICloneable

The UnitAttributes type exposes the following members.

Constructors
  NameDescription
Public methodUnitAttributes
Creates a new default UnitAttributes attributes instance. The default values are Units.Automatic, FormatTypes.Automatic.
Public methodUnitAttributes(Units, FormatTypes)
Creates a new UnitAttributes attributes instance with the given parameters.
Top
Properties
  NameDescription
Public propertyFormat
Gets or sets the format to use.
Public propertyUnit
Gets or sets the unit to use.
Top
Methods
  NameDescription
Public methodClone
Clones the object.
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next