Drawing Class

The Drawing class represents a drawing in Tekla Structures.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class Drawing : DatabaseObject

The Drawing type exposes the following members.

Properties
  NameDescription
Public propertyCommitMessage
Gets the commit message
Public propertyCreationDate
The drawing creation date.
Public propertyDrawingTypeStr
The type of the drawing
Public propertyIsFrozen
Describes whether the drawing is frozen.
Public propertyIsIssued
Describes whether the drawing is issued.
Public propertyIsIssuedButModified
Describes whether the drawing is issued but modified since it was issued.
Public propertyIsLocked
Describes whether the drawing is locked.
Public propertyIsLockedBy
Gets the logged in username that set the drawing to locked
Public propertyIsMasterDrawing
Describes whether the drawing is a master drawing (shown with a special symbol on the drawing list).
Public propertyIsReadyForIssue
Describes whether the drawing is ready for issue.
Public propertyIsReadyForIssueBy
Gets the logged in username that set the drawing Ready for issue
Public propertyIssuingDate
The drawing issuing date.
Public propertyLayout
Gets the drawing layout attributes.
Public propertyMark
The drawing mark.
Public propertyModificationDate
The drawing modification date.
Public propertyName
The name of the drawing.
Public propertyOutputDate
The drawing output date. XS_DISABLE_DRAWING_PLOT_DATE controls whether this date is set.
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertySectionViewStartLabel
Gets the drawing attribute for start label of section view
Public propertyTitle1
The first drawing title.
Public propertyTitle2
The second drawing title.
Public propertyTitle3
The third drawing title.
Public propertyUpToDateStatus
Gets the drawing up to date status.
Top
Methods
  NameDescription
Public methodCommitChanges
Commits the changes made to the drawings database so far. Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo. Commit also executes all messages. Please note that you need to also to save the drawings database to persists the changes to disk.
Public methodCommitChanges(String)
Commits the changes made to the drawings database so far. Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo. Commit also executes all messages. Please note that you need to also to save the drawings database to persists the changes to disk.
Public methodDelete
Deletes the drawing. An active drawing cannot be deleted.
(Overrides DatabaseObjectDelete.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodStatic memberGetIdsOfUnnumberedDrawings
Returns the list of identifiers of those drawings in the input that are NOT up to date regarding numbering in the drawing
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetPlotFileName
Get plot file name.
Public methodGetPlotFileNameExt
Get plot file name.
Public methodGetSheet
Gets the sheet of the drawing.
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodInsert
Inserts the object instance into the database. The inserted instance must be of a real type.
(Inherited from DatabaseObject.)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Overrides DatabaseObjectIsSameDatabaseObject(DatabaseObject).)
Public methodModify
Modifies the instance in the database.
(Inherited from DatabaseObject.)
Public methodPlaceViews
Places views on the sheet. Computes the required size of the views to fit the parts, then places the views so that they fit on the sheet and do not overlap. Adjusts the sheet size if needed.
Public methodSelect
Selects the object instance from the database.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next