AnalysisSubSectionAnalysisSubSectionSubTypeEnum Enumeration

Defines the subsection subtypes.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public enum AnalysisSubSectionSubTypeEnum
Members
  Member nameValueDescription
UNKNOWN_SUBTYPE0 The subsection subtype is unknown.
I_HOT_ROLLED1001 The hot rolled I profile.
I_WELDED_SYMMETRICAL1002 The first symmetrically welded I profile.
I_WELDED_UNSYMMETRICAL1003 The first unsymmetrically welded I profile.
I_WELDED_SYMMETRICAL21004 The second symmetrically welded I profile.
I_WELDED_UNSYMMETRICAL21005 The second unsymmetrically welded I profile.
L_HOT_ROLLED2001 The hot rolled L profile.
L_COLD_ROLLED2002 The cold rolled L profile.
Z_COLD_ROLLED3001 The cold rolled Z profile.
U_HOT_ROLLED4001 The hot rolled U profile.
U_COLD_ROLLED4002 The cold rolled U profile.
PL_DEFAULT5001 The default PL profile.
D_CIRCULAR6001 The circular D profile.
D_ELLIPTICAL6002 The elliptical D profile.
PD_CIRCULAR7001 The circular PD profile.
PD_ELLIPTICAL7002 The elliptical PD profile.
PD_CIRCULAR_TAPERED7003 The circular tapered PD profile.
P_SQUARE8001 The square P profile.
P_RECTANGULAR8002 The rectangular P profile.
P_ALTERING_HEIGHT8003 The altering height P profile.
C_HOT_ROLLED9001 The hot rolled C profile.
C_COLD_ROLLED9002 The cold rolled C profile.
T_HOT_ROLLED10001 The hot rolled T profile.
T_PARAMETRIC10002 The parametric T profile.
HK_SYMMETRICAL11001 The symmetrical HK profile.
HK_UNSYMMETRICAL11002 The unsymmetrical HK profile.
HQ_CENTERED13001 The centered HQ profile.
HQ_NOT_CENTERED13002 The not centered HQ profile.
ZZ_SYMMETRICAL15001 The symmetrical ZZ profile.
ZZ_NOT_SYMMETRICAL15002 The unsymmetrical ZZ profile.
CC_SYMMETRICAL16001 The symmetrical CC profile.
CC_NOT_SYMMETRICAL16002 The unsymmetrical CC profile.
CW_SYMMETRICAL17001 The symmetrical CW profile.
CW_UNSYMMETRICAL17002 The unsymmetrical CW profile.
CU_SYMMETRICAL18001 The symmetrical CU profile.
CU_NOT_SYMMETRICAL18002 The unsymmetrical CU profile.
EB_SYMMETRICAL19001 The symmetrical EB profile.
EB_NOT_SYMMETRICAL19002 The unsymmetrical EB profile.
BF_DEFAULT20001 The default BF profile.
SPD_CIRCULAR21001 The circular SPD profile.
SPD_ELLIPTICAL21002 The elliptical SPD profile.
SPD_CIRCULAR_TAPERED21003 The circular tapered SPD profile.
EC_SYMMETRICAL22001 The symmetrical EC profile.
EC_NOT_SYMMETRICAL22002 The unsymmetrical EC profile.
ED_DEFAULT23001 The default ED profile.
EE_DEFAULT24001 The default EE profile.
EF_DEFAULT25001 The default EF profile.
EZ_DEFAULT26001 The default EZ profile.
EW_DEFAULT27001 The default EW profile.
RCDL_SYMMETRICAL102001 The symmetrical RCDL profile.
RCDL_UNSYMMETRICAL102002 The unsymmetrical RCDL profile.
RCXX_DEFAULT103001 The default RCXX profile.
RCL_DEFAULT104001 The default RCL profile.
RCDX_SYMMETRICAL105001 The symmetrical RCDX profile.
RCDX_UNSYMMETRICAL105002 The first unsymmetrical RCDX profile.
RCDX_UNSYMMETRICAL2105003 The second unsymmetrical RCDX profile.
RCX_DEFAULT106001 The default RCX profile.
COMPONENT_FIRST999001 The component first type.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next