PickerInputObject Class

The PickerInputObject class represents a pick of an object in a view. Used for values asked by UI.Picker.PickObject(string Prompt, out DrawingObject PickedObject, out ViewBase PickedView).
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public class PickerInputObject : PickerInputWithinAView

The PickerInputObject type exposes the following members.

Constructors
  NameDescription
Public methodPickerInputObject
Creates a new PickerInputObject instance representing the pick of a drawing object in a view.
Top
Properties
  NameDescription
Public propertyPickedObject
Gets or sets the picked object in the view.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PickerInputWithinAViewIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next