CylindricalSurface Class

The CylindricalSurface class defines a cylindrical surface contour.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class CylindricalSurface : BendSurface

The CylindricalSurface type exposes the following members.

Constructors
  NameDescription
Public methodCylindricalSurface(Arc, Double)
Initializes a new instance of the CylindricalSurface class from a base arc and a height. This is the recommended constructor if no intermediate points are desired along the lateral boundaries of the bend surface.
Public methodCylindricalSurface(ListPoint, ListPoint, Line, Vector)
Initializes a new instance of the CylindricalSurface class from the cone lateral boundaries and the center line. This is the recommended constructor if fine grained control is desired over the lateral boundaries of the surface.
Public methodCylindricalSurface(Vector, Vector, ListPoint, ListPoint)
Initializes a new instance of the CylindricalSurface class with given parameters. The boundaries are defined by the lateral boundaries (i.e. the points on the sides of the curved part of the cylinder). The side boundaries are defined by the two first points and the two last points of the lateral boundaries.
Public methodCylindricalSurface(Vector, Vector, LineSegment, LineSegment)
Initializes a new instance of the CylindricalSurface class with given parameters. The boundaries are defined by the side boundaries (i.e. generator lines of the cylinder).
Top
Properties
  NameDescription
Public propertyRadius
Gets radius of the cylindrical surface.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next