FormingStates Class

FormingStates class which contains different forming options.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.FormingFormingStates

Namespace:  Tekla.Structures.Forming
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class FormingStates : ICloneable

The FormingStates type exposes the following members.

Constructors
  NameDescription
Public methodFormingStates
Initializes a new instance of the FormingStates class.
Public methodFormingStates(DeformingType)
Initializes a new instance of the FormingStates class.
Public methodFormingStates(FoldingType)
Initializes a new instance of the FormingStates class.
Public methodFormingStates(WrappingType)
Initializes a new instance of the FormingStates class.
Public methodFormingStates(DeformingType, FoldingType, WrappingType)
Initializes a new instance of the FormingStates class.
Top
Properties
  NameDescription
Public propertyDeforming
Gets or sets the deforming type.
Public propertyFolding
Gets or sets the folding type.
Public propertyWrapping
Gets or sets the wrapping type.
Top
Methods
  NameDescription
Public methodClone
Method for cloning the current object.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next