ClashCheckHandler Class

The ClashCheckHandler class contains clash check methods.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelClashCheckHandler

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ClashCheckHandler

The ClashCheckHandler type exposes the following members.

Methods
  NameDescription
Public methodGetIntersectionBoundingBoxes
Get a list of bounding boxes (AABB) of the clashing volumes of two objects.
Public methodRunClashCheck
Starts the clash checking. Uses advanced options sa option values.
Public methodRunClashCheckWithOptions(Boolean, Boolean, Double, Boolean)
Starts the clash checking with options.
Public methodRunClashCheckWithOptions(Boolean, Boolean, Boolean, Double, Boolean)
Starts the clash checking with options.
Public methodStopClashCheck
Stops the clash checking.
Top
Examples
using Tekla.Structures.Model;

public class Example
{
       public void Exmaple1()
       {
           Model MyModel = new Model();

           ClashCheckHandler ClashCheck = MyModel.GetClashCheckHandler();
           ClashCheck.RunClashCheck();
           ClashCheck.StopClashCheck();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next