Tekla.Structures.Drawing Namespace

The Tekla.Structures.Drawing namespace includes the functionality to insert, select, modify or delete objects inside a Tekla Structures drawing. The namespace also includes possibilites to query different kind of data from the current drawing instance, such as information about the currently selected objects. The namespace offers the functionality through .NET remoting and the COM interface. See the DrawingHandler class to get started with drawings.
Classes
  ClassDescription
Public classAlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType
The AlongLineOrWithLeaderLineAndParentObjectAlongPartPlacingType class defines a placing type that places the object using the along line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line and rotated to be at the same angle as the connected part.
Public classAlongLineOrWithLeaderLinePlacingType
The AlongLineOrWithLeaderLinePlacingType class defines a placing type that places the object using the along line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line.
Public classAlongLinePlacing
The AlongLinePlacing class defines a placing where the object is located and moved along a line defined by two points.
Public classAlongLinePlacingType
The AlongLinePlacingType class defines a placing type that places the object using the along line placing.
Public classAlongPartCenteredPlacingType
The AlongPartCenteredPlacingType class defines a placing type that places the object using the along line placing. The line used will be the part's edge in the center of that line.
Public classCode exampleAngleDimension
The AngleDimension class defines an angle dimension between two lines. The dimension can be shown by a triangle or in degrees. You can also enter the triangle base length.
Public classCode exampleAngleDimensionAttributes
The AngleDimensionAttributes class contains the attributes for angle dimensions.
Public classCode exampleArc
The Arc class defines an arc that is a two-point line with an optional curve radius. It can be created using either two points and a radius or three points.
Public classArcArcAttributes
The ArcAttributes class is the attributes class for the arc.
Public classArrowheadAttributes
The ArrowheadAttributes class handles attributes related to arrowheads of different objects.
Public classAssemblyDrawing
The AssemblyDrawing class is for handling assembly drawings.
Public classAttributesBase
The AttributesBase class is the class that all the main attributes that can load attribute files inherit from.
Public classBaseLinePlacing
The BaseLinePlacing class defines a placing where the object is placed using a line as a reference. This will thus define the object's X-axis along that line.
Public classBaseLinePlacingType
The BaseLinePlacingType class defines a placing type that places the object using the base line placing.
Public classBaseLineWithArrowAtEndPointPlacingType
The BaseLineWithArrowAtEndPointPlacingType class defines a placing type that places the object using the base line placing. The line is drawn and will have an arrow at the end point.
Public classBaseLineWithArrowAtStartPointPlacingType
The BaseLineWithArrowAtStartPointPlacingType class defines a placing type that places the object using the base line placing. The line is drawn and will have an arrow at the start point.
Public classBolt
The Bolt class contains methods related to bolts. A bolt is a drawing object derived from a model object. It represents a drawing bolt that has a reference to the actual bolt in the model database.
Public classBoltBoltAttributes
The BoltAttributes class is the attributes class for the bolt.
Public classCannotCreateSectionViewFrom3dView
The CannotCreateSectionViewFrom3dView class defines the exception that is thrown when a user tries to create a section view from a 3d view.
Public classCannotDeleteActiveDrawingException
The CannotDeleteActiveDrawingException class defines the exception that is thrown when a user tries to delete a drawing that is active.
Public classCannotGetAttributeForPluginDueToIncorrectTypeException
The CannotGetAttributeForPluginDueToIncorrectTypeException class defines the exception that is thrown when Plugin.GetAttribute is called but the type is incorrect.
Public classCannotGetAttributeForPluginDueToInexistantFieldException
The CannotGetAttributeForPluginDueToInexistantFieldException class defines the exception that is thrown when Plugin.GetAttribute is called but the field does not exist.
Public classCannotGetAttributeForPluginException
The CannotGetAttributeForPluginException class defines the exception that is thrown when Plugin.GetAttribute is called but the attribute cannot be fetched.
Public classCannotInsertDrawingException
The CannotInsertDrawingException class defines the exception that is thrown when a user tries to insert a drawing when another drawing is active.
Public classCannotLoadAttributesException
The CannotLoadAttributesException class defines the exception that is thrown when the loading of attributes failed.
Public classCannotModifyNonActiveDrawingException
The CannotModifyNonActiveDrawingException class defines the exception that is thrown when a user tries to modify a drawing that is not set as active.
Public classCannotPerformOperationDrawingEditorMustBeClosedException
The CannotPerformOperationDrawingEditorMustBeClosedException class defines the exception that is thrown when a user tries to do an operation which requires the drawing editor to be closed.
Public classCannotPerformOperationDrawingIsActiveException
The CannotPerformOperationDrawingIsActiveException class defines the exception that is thrown when a user tries to do an operation which requires that the drawing is not active.
Public classCannotPerformOperationDrawingMustBeActiveException
The CannotPerformOperationDrawingMustBeActiveException class defines the exception that is thrown when a user tries to do an operation which requires that the drawing is active.
Public classCannotPerformOperationDrawingNotUpToDateException
The CannotPerformOperationDrawingNotUpToDateException class defines the exception that is thrown when a user tries to do an operation which requires that the drawing is active.
Public classCannotPerformOperationNumberingNotUpToDate
The CannotPerformOperationNumberingNotUpToDate class defines the exception that is thrown when a user tries to do an operation which requires that numbering is up to date.
Public classCannotSetAttributeForPluginDueToIncorrectTypeException
The CannotSetAttributeForPluginDueToIncorrectTypeException class defines the exception that is thrown when Plugin.SetAttribute is called but the type is incorrect.
Public classCannotSetAttributeForPluginDueToInexistantFieldException
The CannotSetAttributeForPluginDueToInexistantFieldException class defines the exception that is thrown when Plugin.SetAttribute is called but the field does not exist.
Public classCannotSetAttributeForPluginException
The CannotSetAttributeForPluginException class defines the exception that is thrown when Plugin.SetAttribute is called but the attribute cannot be set.
Public classCastUnitDrawing
The CastUnitDrawing class is for handling cast unit drawings.
Public classCode exampleCircle
The Circle class defines the graphical object circle. A circle can also be hatched.
Public classCircleCircleAttributes
The CircleAttributes class is the attributes class of the circle.
Public classClosedGraphicObject
The ClosedGraphicObject class is an abstract base class for all closed graphic objects (the circle, the cloud, the polygon and the rectangle).
Public classClosedGraphicObjectClosedGraphicObjectAttributes
The ClosedGraphicObjectAttributes class is the attributes class for the closed graphic object.
Public classCode exampleCloud
The Cloud class defines a cloud that is a polygon with a specific size set for the bulges.
Public classCloudCloudAttributes
The CloudAttributes class is the attributes class for the cloud.
Public classConnection
The Connection class contains methods related to connections. A connection is a drawing object derived from a model object. It represents a drawing connection that has a reference to the actual connection in the model database.
Public classContainerElement
The ContainerElement class defines container elements. A container element is a mark element that has a frame and contains other mark elements. A container element may also contain container elements to achieve nested frames.
Public classCode exampleContainerView
The ContainerView class contains container views that contain other drawing objects, including other views and container views. The drawing sheet is a container view. Container views do not contain drawing representations of model objects.
Public classCurvedDimensionBase
The CurvedDimensionBase class is the base class for radial and orthogonal curved dimensions.
Public classCurvedDimensionOrthogonal
The CurvedDimensionOrthogonal class defines a curved dimension with orthogonal reference lines.
Public classCurvedDimensionRadial
The CurvedDimensionRadial class defines a curved dimension with radial reference points. The dimension text on the line can be either a distance or an angle value.
Public classCurvedDimensionSetBase
The CurvedDimensionSetBase class is the base class for curved dimension sets which are defined by an arc and a point list.
Public classCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
The CurvedDimensionSetBaseAttributes class contains the attributes for the curved dimensions.
Public classCurvedDimensionSetHandler
The CurvedDimensionSetHandler class contains operations for creating curved dimension sets.
Public classCurvedDimensionSetOrthogonal
The CurvedDimensionSetOrthogonal class defines a curved dimension set with orthogonal reference lines.
Public classCurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes
The CurvedDimensionSetOrthogonalAttributes class contains the attributes for managing all the attributes of the curved dimension with orthogonal reference lines.
Public classCode exampleCurvedDimensionSetRadial
The CurvedDimensionSetRadial class defines a curved dimension set with radial reference lines.
Public classCurvedDimensionSetRadialCurvedDimensionSetRadialAttributes
The CurvedDimensionSetRadialAttributes class contains the attributes for managing all the attributes of the curved dimension with radial reference lines.
Public classCode exampleCurvedSectionMark
The CurvedSectionMark class defines a drawing object that illustrates a curved section in a specific view. In contrast to straight section mark, the curved section mark can only be inserted as a result of creating a curved section view.
Public classCustomLineType
The CustomLineType class defines the custom line types of the drawing objects.
Public classCustomLineTypeCatalog
The CustomLineTypeCatalog provides accessors to fetch the possible custom line types of drawing objects.
Public classDatabaseObject
The DatabaseObject class is a base class for all drawing objects.
Public classCode exampleDetailMark
The DetailMark class defines a drawing object that illustrates a detail in a specific view.
Public classDetailMarkDetailMarkAttributes
The DetailMarkAttributes class is the attributes class for detail marks.
Public classDetailMarkSymbolAttributes
The DetailMarkSymbolAttributes class is for detail mark attributes related to the shape of the connecting symbol.
Public classDetailMarkTagsAttributes
The DetailMarkTagsAttributes class contains attributes for detail mark tags.
Public classDimensionBase
The DimensionBase class is the common base class for all the different dimensions.
Public classCode exampleDimensionLink
The DimensionLink class contains methods related to dimension links. A dimension link is a link between two dimension sets.
Public classDimensionSetBase
The DimensionSetBase class is the common base class for all the different dimension sets. The dimension set base cannot be instantiated.
Public classDimensionSetBaseAttributes
The DimensionSetBaseAttributes class is the base class for all dimension set attributes. The class contains attributes that are common to all dimension sets.
Public classDimensionSetBaseAttributesCombinedDimensionAttributes
The CombinedDimensionAttributes class handles attributes related to the combination of identical parts of dimensions.
Public classDimensionSetBaseAttributesDimensionExaggerationAttributes
The DimensionExaggerationAttributes class handles attributes related to the exaggeration of dimension lines.
Public classDimensionSetBaseAttributesDimensionFormatAttributes
The DimensionFormatAttributes class controls the precision, format and unit of the dimension.
Public classDimensionSetBaseAttributesDimensionPlacingAttributes
The DimensionPlacingAttributes class controls the placing of the dimension.
Public classDimensionSetBaseAttributesDimensionTextAttributes
The DimensionTextAttributes class controls the dimension value representation.
Public classDPMPrinterAttributes
The DPMPrinterAttributes class contains the attributes for controlling the printing.
Public classDrawing
The Drawing class represents a drawing in Tekla Structures.
Public classCode exampleDrawingEnumerator
The DrawingEnumerator class provides the means to iterate through drawing instances. Drawing enumerators are generated by the drawing handler.
Public classCode exampleDrawingEnumeratorBase
The DrawingEnumeratorBase class is a base class for DrawingObjectEnumerator and DrawingEnumerator.
Public classCode exampleDrawingHandler
The DrawingHandler class initializes the interface from a .NET application to Tekla Structures. This object must be created before any actions can be performed on Tekla Structures drawings. When this object is created, it is possible to ask the current active drawing in Tekla Structures, get a list of drawings or create a new drawing.
Public classCode exampleDrawingLink
The DrawingLink class defines a drawing link object in a drawing. When a drawing link is double clicked, the target drawing is opened.
Public classDrawingObject
The DrawingObject class is an abstract base class for all the objects in the drawing. All drawing objects have a database identifier and belong to some view.
Public classDrawingObjectNoAttributes
The NoAttributes class defines attributes for objects that do not contain any attributes.
Public classCode exampleDrawingObjectEnumerator
The DrawingObjectEnumerator class provides the means to iterate through drawing object instances. Drawing object enumerators are generated by the container view and they contain drawing objects that are children of the container view instance.
Public classCode exampleDwgObject
The DwgObject class defines a DWG or DXF object that can be inserted into a drawing.
Public classEdgeChamfer
The EdgeChamfer class contains methods related to edge chamfers. An edge chamfer is a drawing object derived from a model object. It represents a drawing chamfer that has a reference to the actual chamfer in the model database.
Public classEdgeChamferEdgeChamferAttributes
The EdgeChamferAttributes class is the attributes class for the edge chamfer.
Public classElementBase
The ElementBase class is the abstract base class for all mark elements.
Public classEmbeddedObjectAttributes
The EmbeddedObjectAttributes class contains attributes for embedded objects.
Public classEmbeddedObjectBase
The EmbeddedObjectBase class defines an embedded object in a drawing. The object refers to another file in the file system and its drawing representation is updated when a drawing is opened.
Public classEmbeddedObjectFrame
The EmbeddedObjectFrame class defines the frame object for embedded objects.
Public classCode exampleEvents
The Events class allows the user to register event listeners for drawing events.
Public classFontAttributes
The FontAttributes class contains the basic attributes for fonts.
Public classFrame
The Frame class defines a frame that can be given to objects, including texts. A frame is a box around the object. You can specify the color and shape of the box.
Public classCode exampleGADrawing
The GADrawing class is for handling general arrangement drawings in Tekla Structures.
Public classGenericAttributesBase
The GenericAttributesBase class is a base class that shared attributes among many classes use.
Public classGraphicObject
The GraphicObject class is the abstract base class for all graphic objects (the arc, the circle, the cloud, the line, the polygon, the polyline and the rectangle).
Public classGraphicObjectGraphicObjectAttributes
The GraphicObjectAttributes class is the attributes class of the graphic object.
Public classGraphicObjectHatchAttributes
The GraphicObjectHatchAttributes class contains hatch attributes for graphic object hatches.
Public classCode exampleGrid
The Grid class contains methods related to grids. A drawing grid is inserted/removed using the view.
Public classGridGridAttributes
The GridAttributes class is the attributes class for the grid.
Public classCode exampleGridLine
The GridLine class contains methods related to grid lines. A drawing grid line is always a child of a grid object.
Public classGridLineGridLabel
The GridLabel class contains the grid labels of the grid lines, the text label and the insertion points.
Public classGridLineGridLineAttributes
The GridLineAttributes class is the attributes class for the grid line.
Public classHatchAttributes
The HatchAttributes base class, inherited by ModelObjectHatchAttributes and GraphicObjectHatchAttributes, contains hatch attributes.
Public classCode exampleHideable
Accesses the information if this object is hidden or not or if it should be.
Public classCode exampleHyperLink
The HyperLink class defines a hyperlink object in a drawing. When a hyperlink is double clicked, the default browser is launched.
Public classImage
The Image class defines an image that can be inserted into a drawing.
Public classInsidePartAlongPartOrWithLeaderLinePlacingType
The InsidePartAlongPartOrWithLeaderLinePlacingType class defines a placing type that places the object using the base line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line. The base line used is in the middle of the part, aligned with the part.
Public classInsidePartAlongPartPlacingType
The InsidePartAlongPartPlacingType class defines a placing type that places the object using the base line placing. The base line used is in the middle of the part, aligned with the part.
Public classInsidePartHorizontalOrWithLeaderLinePlacingType
The InsidePartHorizontalOrWithLeaderLinePlacingType class defines a placing type that places the object using the base line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line. The base line used is in the middle of the part, aligned with the part. In addition the object will be rotated to be horizontal in the drawing.
Public classInsidePartHorizontalPlacingType
The InsidePartHorizontalPlacingType class defines a placing type that places the object using the base line placing. The base line used is in the middle of the part, aligned with the part. In addition the object will be rotated to be horizontal in the drawing.
Public classCode exampleIntList
The IntList class defines a type safe list of integers.
Public classInvalidAttributesForOperationException
The InvalidAttributesForOperationException class defines the exception that is thrown when an object's attributes are set to something that is not valid for the object.
Public classInvalidPluginPickerInputException
The InvalidPluginPickerInputException class defines the exception that is thrown when UI.Picker is used during a Plugin.Insert call but the previously assigned PluginPickerInput does not correspond to the next UI.Picker call.
Public classInvalidTypeException
The InvalidTypeException class defines the exception that is thrown when a type was not one of the allowed ones.
Public classLayoutAttributes
The LayoutAttributes class contains attributes for controlling the drawing layout.
Public classCode exampleLeaderLine
The LeaderLine class defines a leader line attached to a parent object, for example a Text or a Mark. The LeaderLine can be modified to add/remove elbow points or to change where it is pointing.
Public classLeaderLineAndParentObjectAlongPartPlacingType
The LeaderLineAndParentObjectAlongPartPlacingType class defines a placing type that places the object with a leader line and rotated to be at the same angle as the connected part.
Public classLeaderLinePlacing
The LeaderLinePlacing class defines a placing where the object is placed attached to a leader line.
Public classLeaderLinePlacingType
The LeaderLinePlacingType class defines a placing type that places the object with a leader line.
Public classCode exampleLevelMark
The LevelMark class defines a drawing object that is displayed as a level mark in a drawing. See the Tekla Structures help for more information.
Public classLevelMarkLevelMarkAttributes
The LevelMarkAttributes class contains the attributes for the level mark.
Public classCode exampleLine
The Line class defines a line that is a two-point line with an optional bulge (curve).
Public classLineLineAttributes
The LineAttributes class is the attributes class of the line.
Public classLineTypeAttributes
The LineTypeAttributes class contains basic attributes for lines.
Public classLineTypes
The LineTypes class defines the possible line types that can be used by the drawing objects.
Public classCode exampleLinkAttributes
The LinkAttributes class contains the attributes for controlling the appearance of a link.
Public classLinkBase
The LinkBase class is the base class for links.
Public classLinkFrameAttributes
The LinkFrameAttributes class contains the attributes for controlling the appearance of a link frame.
Public classCode exampleMark
The Mark class represents a mark object that contains a single mark. Several mark objects can be merged into one mark set.
Public classMarkMarkAttributes
The MarkAttributes class defines the mark attributes.
Public classCode exampleMarkBase
The MarkBase class contains general mark information and can be selected and modified with the general attributes.
Public classMarkBaseMarkBaseAttributes
The MarkBaseAttributes class is the attributes class for the mark base.
Public classMarkSet
The MarkSet class defines mark set objects that contain several mark objects merged to one mark set.
Public classMarkSetMarkSetAttributes
The MarkSetAttributes class is the attribute class for the mark set.
Public classModelObject
The ModelObject class is an abstract class for all model objects in the drawing side. The model objects of the drawing side contain identifiers of the actual model objects in the model database. The model objects appear and disappear based on current view properties (view size, settings).
Public classModelObjectHatchAttributes
The ModelObjectHatchAttributes class contains hatch attributes for model object hatches.
Public classMultiDrawing
The MultiDrawing class is for handling multidrawings.
Public classNewLineElement
The NewLineElement class defines a line feed between the desired elements to create multi-row marks.
Public classNormalLineType
The NormalLineType class defines the non-custom line types that can be used by the drawing objects.
Public classOpenGraphicObject
The OpenGraphicObject class is an abstract base class for all open graphic objects (the arc, the line and the polyline).
Public classOpenGraphicObjectOpenGraphicObjectAttributes
The OpenGraphicObjectAttributes class is the attributes class of the open graphic object.
Public classPart
The Part class contains methods related to parts. A part is a drawing object derived from a model object. It represents a drawing part that has a reference to the actual part in the model database.
Public classPartPartAttributes
The PartAttributes class is the attributes class for the part.
Public classPickerInput
The PickerInput class instances can be provided as predefined results of requests through the methods of the UI.Picker class.
Public classPickerInputInterrupt
The PickerInputInterrupt class represents the interruption of picking by the user (e.g. by pressing Escape while requested to pick points). Used for values asked by any UI.Picker.Pick* method where an interrupt happens by the user.
Public classPickerInputNPoints
The PickerInputNPoints class represents a pick of several points in a view. Used for values asked by UI.Picker.PickPoints(StringList Prompts, out PointList PickedPoints, out ViewBase PickedView) and UI.Picker.PickPoints(int NumberOfPicks, StringList Prompts, out PointList PickedPoints, out ViewBase PickedView).
Public classPickerInputObject
The PickerInputObject class represents a pick of an object in a view. Used for values asked by UI.Picker.PickObject(string Prompt, out DrawingObject PickedObject, out ViewBase PickedView).
Public classPickerInputObjectAndAPoint
The PickerInputObjectAndAPoint class represents a pick of an object in a view. It provides both the picked object and the point used to pick the object. Used for values asked by UI.Picker.PickObject(string Prompt, out DrawingObject PickedObject, out ViewBase PickedView, out Point PickedPoint).
Public classPickerInputPoint
The PickerInputPoint class represents a pick of one point in a view. Used for values asked by UI.Picker.PickPoint(string Prompt, out Point PickedPoint, out ViewBase PickedView).
Public classPickerInputPointsWithinAView
The PickerInputPointsWithinAView class is the base class of PickerInput instances that represent a pick of one or more points in a view.
Public classPickerInputThreePoints
The PickerInputThreePoints class represents a pick of three points in a view. Used for values asked by UI.Picker.PickThreePoints(string FirstPrompt, string SecondPrompt, string ThirdPrompt, out Point FirstPickedPoint, out Point SecondPickedPoint, out Point ThirdPickedPoint, out ViewBase PickedView).
Public classPickerInputTwoPoints
The PickerInputTwoPoints class represents a pick of two points in a view. Used for values asked by UI.Picker.PickTwoPoints(string FirstPrompt, string SecondPrompt, out Point FirstPickedPoint, out Point SecondPickedPoint, out ViewBase PickedView).
Public classPickerInputWithinAView
The PickerInputWithinAView class is the base class of PickerInput instances that represent a valid pick of point(s) or object(s) in a view.
Public classPickerInterruptedException
The PickerInterruptedException class defines the exception that is thrown when a user interrupts the picker.
Public classCode examplePlacingAttributes
The PlacingAttributes class contains the basic attributes for determining an object's placing.
Public classCode examplePlacingBase
The PlacingBase class is the base class for placing types. If you set a user defined Placing to an object it will override the PreferredPlacingType set in the object's attributes. Please note that not all objects accept all types. If you try to use the wrong type it will not be accepted (Insert, Modify will fail). (It is strongly recommended to use the PreferredPlacingTypes to assign new Placings to objects.)
Public classPlacingDirectionAttributes
The PlacingDirectionAttributes class contains the basic attributes for placing directions.
Public classPlacingDistanceAttributes
The PlacingDistanceAttributes class contains the basic attributes for placing distances.
Public classPlacingQuarterAttributes
The PlacingQuarterAttributes class contains the basic attributes for placing quarters.
Public classPlacingTypes
The PlacingTypes class defines the different available placing types. Please note that not all objects accept all types. If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
Public classCode examplePlugin
The Plugin class represents a drawing plug-in.
Public classPluginPickerInput
The PluginPickerInput class represents a predefined set of picker inputs that can be provided to a plug-in object. It replaces the interactive selection of points and/or objects by the user when the plug-in is inserted into a drawing through the API.
Public classCode examplePointList
The PointList class defines a type safe point list.
Public classPointPlacing
The PointPlacing class defines a placing where the object is placed at one point (the insertion point) without any additional placing options.
Public classPointPlacingType
The PointPlacingType class defines a placing type where the object is placed at one point (the insertion point) without any additional placing options.
Public classCode examplePolygon
The Polygon class defines a polygon that is a multipoint line which is connected. It can also have a bulge (curved lines).
Public classPolygonPolygonAttributes
The PolygonAttributes class is the attributes class of the polygon.
Public classCode examplePolyline
The Polyline class defines a polyline that is a multipoint line. It can also have a bulge (curved lines).
Public classPolylinePolylineAttributes
The PolylineAttributes class is the attributes class of the polyline.
Public classCode examplePourBreak
The PourBreak class contains methods related to pour breaks. A pour break is a drawing object derived from a model object. It represents a drawing pour break that has a reference to the actual pour break in the model database.
Public classPourBreakPourBreakAttributes
The PourBreakAttributes class is the attributes class for the pour break.
Public classPourObject
The PourObject class contains methods related to pours. A pour is a drawing object derived from a model object. It represents a drawing pour that has a reference to the actual pour in the model database.
Public classPourObjectPourAttributes
The PourAttributes class is the attributes class for the pour.
Public classPreferredMarkPlacingTypes
The PreferredMarkPlacingTypes class contains the available preferred mark placing types. These are allowed to be used for marks. However, there are different mark types and not all types can be used by all marks. If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
Public classCode examplePreferredPlacingTypeBase
The PreferredPlacingTypeBase class is the base class for the preferred placing type. You can set the PreferredPlacingType in the object's attributes to specify how your object should be placed in the drawing. Please note that not all objects accept all types. If you try to use the wrong type it will not be accepted (Insert, Modify will fail). To use valid types you should use the named defaults (PreferredTextPlacingTypes for Text, PreferredMarkPlacingTypes for Mark, PreferredSymbolPlacingTypes for Symbol).
Public classPreferredPlacingTypes
The PreferredPlacingTypes class contains all the available preferred placing types. Please note that not all objects accept all types. If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
Public classPreferredSymbolPlacingTypes
The PreferredSymbolPlacingTypes class contains the available preferred symbol placing types. These are allowed to be used for symbols.
Public classPreferredTextPlacingTypes
The PreferredTextPlacingTypes class contains the available preferred text placing types. These are allowed to be used for texts.
Public classPrintAttributes
The PrintAttributes class contains the attributes for controlling the printing.
Public classPropertyElement
The PropertyElement class may represent any of the many different mark element types, such as the profile, the material and the name. The property is defined by the name and it is converted into a textual value before the mark is drawn.
Public classPropertyElementPropertyElementType
The PropertyElementType class represents the type of a property element.
Public classPropertyElementPropertyElementTypeBoltMarkPropertyElementTypes
The BoltMarkPropertyElementTypes class represents the available property element types for bolt marks.
Public classPropertyElementPropertyElementTypeChamferMarkPropertyElementTypes
The ChamferMarkPropertyElementTypes class represents the available property element types for chamfer marks.
Public classPropertyElementPropertyElementTypeConnectionMarkPropertyElementTypes
The ConnectionMarkPropertyElementTypes class represents the available property element types for connection marks.
Public classPropertyElementPropertyElementTypeDetailMarkPropertyElementTypes
The DetailMarkPropertyElementTypes class represents the available property element types for detail marks.
Public classPropertyElementPropertyElementTypeDetailViewLabelMarkPropertyElementTypes
The DetailViewLabelMarkPropertyElementTypes class represents the available property element types for detail view label marks.
Public classPropertyElementPropertyElementTypeMergedMarkPropertyElementTypes
The MergedMarkPropertyElementTypes class represents the available property element types for merged marks.
Public classPropertyElementPropertyElementTypePartMarkPropertyElementTypes
The PartMarkPropertyElementTypes class represents the available property element types for part marks.
Public classPropertyElementPropertyElementTypePourMarkPropertyElementTypes
The PourMarkPropertyElementTypes class represents the available property element types for pour marks.
Public classPropertyElementPropertyElementTypeReinforcementMarkPropertyElementTypes
The ReinforcementMarkPropertyElementTypes class represents the available property element types for reinforcement marks.
Public classPropertyElementPropertyElementTypeReinforcementMeshMarkPropertyElementTypes
The ReinforcementMeshMarkPropertyElementTypes class represents the available property element types for reinforcement mesh marks.
Public classPropertyElementPropertyElementTypeSectionMarkPropertyElementTypes
The SectionMarkPropertyElementTypes class represents the available property element types for section marks.
Public classPropertyElementPropertyElementTypeSectionViewLabelMarkPropertyElementTypes
The SectionViewLabelMarkPropertyElementTypes class represents the available property element types for section view label marks.
Public classPropertyElementPropertyElementTypeSurfacingMarkPropertyElementTypes
The SurfacingMarkPropertyElementTypes class represents the available property element types for surfacing marks.
Public classPropertyElementPropertyElementTypeViewLabelMarkPropertyElementTypes
The ViewLabelMarkPropertyElementTypes class represents the available property element types for view label marks.
Public classCode exampleRadiusDimension
The RadiusDimension class defines a radius dimension that displays the radius of the given arc.
Public classCode exampleRadiusDimensionAttributes
The RadiusDimensionAttributes class contains attributes to manage all the attributes of a straight dimension.
Public classCode exampleRectangle
The Rectangle class defines a rectangle that is a box made of four lines with orthogonal angles.
Public classRectangleRectangleAttributes
The RectangleAttributes class is the attributes class of the rectangle.
Public classCode exampleRectangleBoundingBox
The RectangleBoundingBox class represents a bounding box for an object, i.e. the surrounding box of the object. The bounding box contains the calculated corner points of the box. The rectangle bounding box is inherited from the axis-aligned bounding box. The AABB also contains methods for getting the center point of the box.
Public classReferenceModel
The ReferenceModel class represents a reference model object in a drawing.
Public classReferenceModelReferenceModelAttributes
The ReferenceModelAttributes class contains attributes for reference model objects.
Public classReinforcementBase
The ReinforcementBase class contains methods related to reinforcements. A reinforcement is a drawing object derived from a model object. It represents a drawing reinforcement that has a reference to the actual reinforcement in the model database.
Public classReinforcementBaseReinforcementBaseAttributes
The ReinforcementBaseAttributes class is the attributes class for the reinforcement.
Public classReinforcementBaseReinforcementGroupAttributes
The ReinforcementGroupAttributes class is the base attributes class for ReinforcementGroup.
Public classReinforcementBaseReinforcementMeshAttributes
The ReinforcementMeshAttributes class is the base attributes class for ReinforcementMesh.
Public classReinforcementBaseReinforcementSetGroupAttributes
The ReinforcementSetGroupAttributes class is the base attributes class for ReinforcementSetGroup.
Public classReinforcementBaseReinforcementSingleAttributes
The ReinforcementSingleAttributes class is the base attributes class for ReinforcementSingle.
Public classReinforcementBaseReinforcementStrandAttributes
The ReinforcementStrandAttributes class is the base attributes class for ReinforcementStrand.
Public classReinforcementGroup
The ReinforcementGroup class defines a reinforcement group in the drawing.
Public classReinforcementMesh
The ReinforcementMesh class defines a reinforcement mesh in the drawing.
Public classReinforcementPulloutElement
The ReinforcementPulloutElement class illustrates the shape and dimensions of a reinforcing bar in a drawing.
Public classReinforcementSetGroup
The ReinforcementSetGroup class defines a reinforcement set group in the drawing. A model rebar set generates one or more groups of rebars for drawing purposes and each group is represented in a drawing as a reinforcement set group. ModelIdentifier is always zero for the ReinforcementSetGroup.
Public classReinforcementSingle
The ReinforcementSingle class defines a single (as in not part of a group) reinforcement bar in the drawing.
Public classReinforcementStrand
The ReinforcementStrand class defines a reinforcement mesh in the drawing.
Public classReportTemplateElement
The ReportTemplateElement class represents a template in the Tekla Structures template library.
Public classCode exampleSectionMark
The SectionMark class defines a drawing object that illustrates a straight section in a specific view.
Public classSectionMarkBase
The SectionMarkBase class is a base class for both the SectionMark class and the CurvedSectionMark class.
Public classSectionMarkBaseSectionMarkAttributes
The SectionMarkAttributes class is the attributes class for section marks.
Public classSectionMarkBaseSectionMarkSymbol
The SectionMarkSymbol class is for section mark attributes related to the shape of the connecting symbol.
Public classSectionMarkBaseSectionMarkTagAttributes
The SectionMarkTagAttributes class contains attributes for section mark tags.
Public classSectionMarkBaseSectionMarkTagsAttributes
The SectionMarkTagsAttributes class contains attributes for section mark tags.
Public classSinglePartDrawing
The SinglePartDrawing class is for handling single part drawings.
Public classSize
The Size class contains the width and height properties.
Public classSpaceElement
The SpaceElement class defines a space between the desired elements.
Public classStraightDimension
The StraightDimension class defines straight dimensions.
Public classStraightDimensionStraightDimensionAttributes
The StraightDimensionAttributes class contains the attributes of the straight dimension.
Public classStraightDimensionSet
The StraightDimensionSet class defines a straight dimension set.
Public classCode exampleStraightDimensionSetStraightDimensionSetAttributes
The StraightDimensionSetAttributes class contains the attributes for managing all the attributes of the straight dimension.
Public classStraightDimensionSetHandler
The StraightDimensionSetHandler class contains operations for creating and modifying straight dimension sets.
Public classCode exampleStringList
The StringList class defines a type safe string collection.
Public classSurfacing
The Surfacing class contains methods related to surfacings. A surfacing is a drawing object derived from a model object. It represents a drawing surfacing that has a reference to the actual surfacing in the model database.
Public classSurfacingSurfacingAttributes
The SurfacingAttributes class is the attributes class for the surfacing.
Public classCode exampleSymbol
The Symbol class defines a drawing object that is displayed as a symbol in a drawing. Symbols are located in the environment directory under the folder named "symbols" in .sym files that can contain up to 255 symbols. Symbol files can be created with SymEd. See the Tekla Structures help for more information.
Public classSymbolSymbolAttributes
The SymbolAttributes class contains the attributes for the symbol.
Public classSymbolElement
The SymbolElement class represents a symbol in the Tekla Structures symbol library.
Public classSymbolInfo
The SymbolInfo class holds symbol information: the symbol file and the symbol index in the symbol file.
Public classSymbolLibrary
The SymbolLibrary class is for handling symbol libraries.
Public classTeklaStructuresDrawingsApplicationException
The TeklaStructuresDrawingsApplicationException class defines the base class for all exceptions that can be thrown while using Tekla.Structures.Drawing.
Public classTemplateInfo
The TemplateInfo class holds template information.
Public classText
The Text class defines a drawing object that can hold a text string and is shown in a drawing.
Public classTextTextAttributes
The TextAttributes class is the attributes class for the text.
Public classTextElement
The TextElement class defines a user-defined text in a mark content.
Public classCode exampleTextFile
The TextFile class defines a text file object in a drawing.
Public classTextFileTextFileAttributes
The TextFileAttributes class contains the attributes for the text file object.
Public classUnitAttributes
The UnitAttributes class handles attributes related to units and formatting of values.
Public classUserDefinedElement
The UserDefinedElement class represents a user-defined attribute specified by its name. A user-defined element is converted into a textual value before it is drawn.
Public classCode exampleView
The View class contains methods related to views. Views are views that contain other drawing objects, excluding other views. Views also contain drawing representations of model objects.
Public classViewViewAttributes
The ViewAttributes class contains the attributes for the view.
Public classViewViewMarkSymbolAttributes
The ViewMarkSymbolAttributes class contains symbol attributes for view mark tags.
Public classViewViewMarkTagAttributes
The ViewMarkTagAttributes class contains attributes for view mark tags.
Public classViewViewMarkTagsAttributes
The ViewMarkTagsAttributes class contains attributes for view mark tags.
Public classViewViewShorteningAttributes
The ViewShorteningAttributes class sets the shortening attributes for the view. If CutParts is set to true, the other values are applied. If it is false, none of the other values matter.
Public classViewBase
The ViewBase class is a base class for both the ContainerView class and the View class.
Public classViewMarkBasicSymbolAttributes
The ViewMarkBasicSymbolAttributes class contains basic attributes for mark symbols.
Public classViewMarkBasicTagAttributes
The ViewMarkBasicTagAttributes class contains basic attributes for view mark tags.
Public classWeld
The Weld class represents weldings in drawing views that refer to actual welds in the model database. It has properties and methods to control the graphical representation of welding lines. Instances of Weld class cannot be inserted with code. These appear in drawings when views are created/updated. To modify its graphical representation, attributes of Weld class can use .welo setting files.
Public classWeldWeldAttributes
The WeldAttributes class is the attributes class for the weld.
Public classCode exampleWeldMark
The WeldMark class defines a drawing object that illustrates a weld mark in a specific view. WeldMark class refers to welding marks that appear when creating/updating drawing views. In this case, ModelIdentifier has a value. WeldMark class also refers to weld marks created with drawing editor UI. In this case, ModelIdentifier value is zero. Graphical representation of welding marks (line and text properties) can be modified using .wel setting files. The welding mark settting files (.wls) cannot be used to modify instances of WeldMark class.
Public classWeldMarkSeamVisibilityAttributes
The SeamVisibilityAttributes class is the attributes class for the weld seam visibility.
Public classWeldMarkWeldMarkAttributes
The WeldMarkAttributes class is the attributes class for the weld mark attributes.
Interfaces
  InterfaceDescription
Public interfaceIAxisAlignedBoundingBox
The IAxisAlignedBoundingBox interface is implemented by objects that have an axis aligned bounding box.
Public interfaceIHasChildren
The IHasChildren interface is implemented by objects that have child objects.
Public interfaceIHideable
The IHideable interface is used for each object that can be hidden in the drawing.
Public interfaceIIsEqual
The IIsEqual interface is for comparing objects using the function IsEqual().
Public interfaceIMovableRelative
The IMovableRelative interface is implemented by objects that can be moved.
Public interfaceIObjectAlignedBoundingBox
The IObjectAlignedBoundingBox interface is implemented by objects that have an object aligned bounding box.
Public interfaceIPlacing
The IPlacing interface is for objects that can have different placings.
Public interfaceIPreferredPlacing
The IPreferredPlacing interface is for objects that can have different preferred placing types.
Public interfaceIRelatedObjects
The IRelatedObjects interface is implemented by objects that have related objects.
Public interfaceIResizeable
The IResizeable interface is implemented by objects that can be resized.
Delegates
Enumerations
  EnumerationDescription
Public enumerationAngleTypes
The different types for angle dimensions.
Public enumerationArrowheadPositions
The positions of the arrowheads on the line.
Public enumerationArrowheadTypes
The arrowhead types.
Public enumerationAutoSizeOptions
Options for controlling how the sheet size is calculated when the SizeDefinitionMode is AutoSize.
Public enumerationBoltRepresentation
The bolt representations.
Public enumerationCastUnitDrawingCastUnitDrawingCreationType
Defines the Cast Unit Drawing Creation type.
Public enumerationDetailMarkDetailMarkAttributesDetailBoundaryShape
The boundary shapes of the detail mark.
Public enumerationDimensionSetBaseAttributesCombineFormats
The combined dimension formats.
Public enumerationDimensionSetBaseAttributesCurvedDimensionTypes
The type of the curved dimension.
Public enumerationDimensionSetBaseAttributesDimensionTextPlacings
The placing types of the dimension value text.
Public enumerationDimensionSetBaseAttributesDimensionTypes
The dimension types.
Public enumerationDimensionSetBaseAttributesDimensionValueFormats
The dimension value formats.
Public enumerationDimensionSetBaseAttributesDimensionValuePrecisions
The value precisions for the dimensions.
Public enumerationDimensionSetBaseAttributesDimensionValueUnits
The units usable with the dimensions.
Public enumerationDimensionSetBaseAttributesExaggerationDirections
The direction of the exaggeration.
Public enumerationDimensionSetBaseAttributesExaggerationOrigins
The origin of the exaggeration.
Public enumerationDimensionSetBaseAttributesExtensionLineTypes
The extension line types.
Public enumerationDimensionSetBaseAttributesFrameTypes
The frame types around the dimension values.
Public enumerationDimensionSetBaseAttributesPlacings
The placing types of the objects.
Public enumerationDimensionSetBaseAttributesShortDimensionTypes
The position of the short dimension value.
Public enumerationDotPrintAreaType
The print area type.
Public enumerationDotPrintColor
Output color mode.
Public enumerationDotPrintOrientationType
The print orientation type.
Public enumerationDotPrintOutputType
The printer output type.
Public enumerationDotPrintPaperSize
The paper size.
Public enumerationDotPrintScalingType
The print scaling type.
Public enumerationDotPrintToMultipleSheet
The print to multiple sheet type.
Public enumerationDrawingColors
The colors used in Tekla.Structures.Drawing.
Public enumerationDrawingHandlerMessageExecutionModeEnum
The message execution modes of Tekla Structures.
Public enumerationDrawingHatchColors
The hatch colors used in Tekla.Structures.Drawing.
Public enumerationDrawingUpToDateStatus
The drawing up to date status.
Public enumerationEmbeddedObjectScalingOptions
The options for controlling the scaling of the objects in the drawing.
Public enumerationEventsDrawingUpdateTypeEnum
The types of drawing update event.
Public enumerationFormatTypes
The available format types.
Public enumerationFrameTypes
The available frame styles around the object.
Public enumerationHideableHiddenFlags
The flag for keeping track of objects hidden status.
Public enumerationHideableShouldBeHiddenFlags
The flag for keeping track if object should be hidden.
Public enumerationIncludeRevisionMarkEnum
Options for including a revision info in file name
Public enumerationLeaderLineLeaderLineTypes
The different types of leader lines available.
Public enumerationLevelMarkLevelMarkType
Defines options about how the level mark is shown.
Public enumerationLineTypesEnum
The line types (the presentation of the line).
Public enumerationMarkBaseMarkBaseAttributesTextAlignOptions
Enumeration of the possible text alignment values.
Public enumerationMarkSymbolShape
The mark symbol shapes for the detail mark.
Public enumerationPartRepresentation
The part representations.
Public enumerationReinforcementBaseHookedEndSymbolTypes
The available hooked end symbol types. See Tekla Structures help, "Reinforcement appearance", for more information.
Public enumerationReinforcementBaseReinforcementRepresentationTypes
The available reinforcement representation types. See Tekla Structures help, "Reinforcement appearance", for more information.
Public enumerationReinforcementBaseReinforcementVisibilityTypes
The available reinforcement visibility types. Only applies to bar groups and meshes. See Tekla Structures help, "Setting the visibility of reinforcement in drawings", for more information.
Public enumerationReinforcementBaseStraightEndSymbolTypes
The available straight end symbol types. See Tekla Structures help, "Reinforcement appearance", for more information.
Public enumerationReinforcementPulloutElementEndSymbols
The shape of the bar ends in the pull-out.
Public enumerationReinforcementPulloutElementRotation
The rotation of the pull-out.
Public enumerationScalingOptions
The options for controlling the scaling of the objects in the drawing.
Public enumerationSectionMarkBaseSectionMarkSymbolSymbolShapes
The possible shapes of the section mark symbol.
Public enumerationSectionMarkBaseSectionMarkTagAttributesTagShowOnSide
The values that determine on which side(s) the mark tag text is shown.
Public enumerationSectionMarkBaseSectionMarkTagAttributesTagTextRotation
The mark tag text rotation values.
Public enumerationSizeDefinitionMode
Controls the size definition mode of the drawing sheet. Set the mode to SizeDefinitionMode.SpecifiedSize if you want to force the sheet to a certain size.
Public enumerationSurfacingRepresentation
The surfacing representations.
Public enumerationTagLocation
The mark tag location values.
Public enumerationTextAlignment
The alignment of the text.
Public enumerationUnits
The available unit types.
Public enumerationViewHorizontalLabelPosition
The horizontal label position types.
Public enumerationViewLabelLineLengthType
The label line length types.
Public enumerationViewShorteningCutPartType
The vertical label position types.
Public enumerationViewVerticalLabelPosition
The vertical label position types.
Public enumerationViewViewTypes
The possible types of views.
Public enumerationWeldRepresentation
The weld representations.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next