OperatorType Enumeration

The operator type defines the operators between two filter expressions.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public enum OperatorType
Members
  Member nameValueDescription
IS_EQUAL1 The "is equal" operator.
IS_NOT_EQUAL2 The "is not equal" operator.
BOOLEAN_OR3 The Boolean OR operator.
BOOLEAN_AND4 The Boolean AND operator.
SMALLER_THAN5 The "smaller than" operator.
SMALLER_OR_EQUAL6 The "smaller or equal" operator.
GREATER_THAN7 The "greater than" operator.
GREATER_OR_EQUAL8 The "greater or equal" operator.
CONTAINS9 The "contains" string operator.
NOT_CONTAINS10 The "not contains" string operator.
STARTS_WITH11 The "starts with" string operator.
NOT_STARTS_WITH12 The "not starts with" string operator.
ENDS_WITH13 The "ends with" string operator.
NOT_ENDS_WITH14 The "not ends with" string operator.
EARLIER_THAN15 The "earlier than" operator.
EARLIER_OR_EQUAL16 The "earlier or equal" operator.
LATER_THAN17 The "later than" operator.
LATER_OR_EQUAL18 The "later or equal" operator.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next