TextElement Class

The TextElement class defines a user-defined text in a mark content.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class TextElement : ElementBase

The TextElement type exposes the following members.

Constructors
  NameDescription
Public methodTextElement(String)
Creates a new text element instance with the given textual value.
Public methodTextElement(String, FontAttributes)
Creates a new text element instance with the given textual value and font.
Top
Properties
  NameDescription
Public propertyFont
The font of the text element.
Public propertyValue
The textual value of the text element.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next