ProfileCatalog Class

The ProfileCatalog class represents a group of controls to select profiles using the profile catalogs.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class ProfileCatalog : UserControl

The ProfileCatalog type exposes the following members.

Constructors
  NameDescription
Public methodProfileCatalog
Initiates a new instance of the control.
Public methodProfileCatalog(String)
Initiates a new instance of the control selecting the given profile.
Top
Properties
  NameDescription
Public propertyButtonText
Gets and sets the text of the button control.
Public propertySelectedProfile
The selected profile in the control.
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the profile selection dialog is closed.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next