Integer Structure

The Integer datatype.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
[TypeConverterAttribute(typeof(IntegerConverter))]
public struct Integer : IXmlSerializable, IIntDataType, 
	IDataType

The Integer type exposes the following members.

Constructors
  NameDescription
Public methodInteger
Creates a new integer datatype instance.
Top
Properties
  NameDescription
Public propertyValue
The value of the integer datatype.
Top
Methods
  NameDescription
Public methodEquals
Returns a value that indicates whether the current instance is equal to the given object.
(Overrides ValueTypeEquals(Object).)
Public methodGetHashCode
Returns the hash code for the current instance.
(Overrides ValueTypeGetHashCode.)
Public methodGetSchema
Gets the XML Schema for the datatype.
Public methodReadXml
Parses a new value from the given reader.
Public methodToString
Returns the string representation of the object.
(Overrides ValueTypeToString.)
Public methodWriteXml
Writes the value as XML to the given writer.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Compares an int value with a Datatype.Integer value.
Public operatorStatic member(Int32 to Integer)
Converts from int to Datatype.Integer.
Public operatorStatic member(Integer to Int32)
Converts from Datatype.Integer to int.
Public operatorStatic memberInequality
Compares an int value with a Datatype.Integer value.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next