EnumE Structure

The Enum datatype generic.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
[TypeConverterAttribute(typeof(EnumConverter))]
public struct Enum<E> : IXmlSerializable, IDataType
where E : struct, new()

Type Parameters

E
The enum to handle.

The EnumE type exposes the following members.

Properties
  NameDescription
Public propertyValue
Gets or sets the value.
Top
Methods
  NameDescription
Public methodGetSchema
Public methodReadXml
Public methodWriteXml
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next