InputObjectTypeAttribute Class

The InputObjectTypeAttribute class is used for storing the type of the input. Based on the type the system can then correctly ask for user input in the creation. The attribute is initialized from the custom attribute [InputObjectType(ConnectionBase.InputObjectType.INPUTOBJECT_PART)] in the connection source.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsInputObjectTypeAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class InputObjectTypeAttribute : Attribute

The InputObjectTypeAttribute type exposes the following members.

Constructors
  NameDescription
Public methodInputObjectTypeAttribute(Int32)
The custom attribute [InputObjectType()] uses this to store the input object type to the system. This is not to be used by itself.
Public methodInputObjectTypeAttribute(ConnectionBaseInputObjectType)
The custom attribute [InputObjectType()] uses this to store the input object type to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
The custom attribute [InputObjectType()] uses this to store the input object type to the system. This is not to be used by itself.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next