DimensionLink Class

The DimensionLink class contains methods related to dimension links. A dimension link is a link between two dimension sets.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class DimensionLink : DrawingObject

The DimensionLink type exposes the following members.

Constructors
  NameDescription
Public methodDimensionLink
Creates a new DimensionLink instance.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Public methodDelete
Unlinks the dimensions in the current drawing.
(Overrides DatabaseObjectDelete.)
Public methodGetDimension1
Gets the first one of the linked dimensions.
Public methodGetDimension2
Gets the second one of the linked dimensions.
Public methodInsert
Links the dimensions in the drawing.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
NOT YET IMPLEMENTED.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the drawing DimensionLink from the current drawing database.
(Overrides DatabaseObjectSelect.)
Top
Examples
The following example creates two dimensions in the drawing sheet and links them:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if (MyDrawingHandler.GetConnectionStatus())
           {
               StraightDimension Dimension1 = new StraightDimension(MyDrawingHandler.GetActiveDrawing().GetSheet(),
                   new Point(0, 0, 0), new Point(100, 0, 0), new Vector(0, -1, 0), 100.0);
               StraightDimension Dimension2 = new StraightDimension(MyDrawingHandler.GetActiveDrawing().GetSheet(),
                   new Point(0, 0, 0), new Point(0, 100, 0), new Vector(-1, 0, 0), 100.0);

               Dimension1.Insert();
               Dimension2.Insert();

               StraightDimensionSet DimSet1 = Dimension1.GetDimensionSet() as StraightDimensionSet;
               StraightDimensionSet DimSet2 = Dimension2.GetDimensionSet() as StraightDimensionSet;

               DimensionLink DimLink = new DimensionLink(DimSet1, DimSet2);
               DimLink.Insert();
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next