DimensionLink Class

The DimensionLink class contains methods related to dimension links. A dimension link is a link between two dimension sets.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class DimensionLink : DrawingObject

The DimensionLink type exposes the following members.

Constructors
  NameDescription
Public methodDimensionLink
Creates a new DimensionLink instance.
Top
Properties
  NameDescription
Public propertyAttributes
Gets or sets the attributes of the current object. Only attributes of the same type as the object are allowed.
(Inherited from DrawingObject.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Top
Methods
  NameDescription
Public methodDelete
Unlinks the dimensions in the current drawing.
(Overrides DatabaseObjectDelete.)
Public methodGetDimension1
Gets the first one of the linked dimensions.
Public methodGetDimension2
Gets the second one of the linked dimensions.
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Links the dimensions in the drawing.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
NOT YET IMPLEMENTED.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the drawing DimensionLink from the current drawing database.
(Overrides DatabaseObjectSelect.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
The following example creates two dimensions in the drawing sheet and links them:
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if (MyDrawingHandler.GetConnectionStatus())
           {
               StraightDimension Dimension1 = new StraightDimension(MyDrawingHandler.GetActiveDrawing().GetSheet(),
                   new Point(0, 0, 0), new Point(100, 0, 0), new Vector(0, -1, 0), 100.0);
               StraightDimension Dimension2 = new StraightDimension(MyDrawingHandler.GetActiveDrawing().GetSheet(),
                   new Point(0, 0, 0), new Point(0, 100, 0), new Vector(-1, 0, 0), 100.0);

               Dimension1.Insert();
               Dimension2.Insert();

               StraightDimensionSet DimSet1 = Dimension1.GetDimensionSet() as StraightDimensionSet;
               StraightDimensionSet DimSet2 = Dimension2.GetDimensionSet() as StraightDimensionSet;

               DimensionLink DimLink = new DimensionLink(DimSet1, DimSet2);
               DimLink.Insert();
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next