LoadLine Class

The LoadLine class defines a linearly-distributed force or torsion.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LoadLine : Load

The LoadLine type exposes the following members.

Constructors
  NameDescription
Public methodLoadLine
Creates a new load line instance.
Top
Properties
  NameDescription
Public propertyDistanceA
The distance a (for shortening or dividing the length of a line load).
Public propertyDistanceB
The distance b (for shortening or dividing the length of a line load).
Public propertyLoadForm
The load form.
Public propertyP1
The load magnitude vector at the start position. The values are given in the local coordinate system of the load (not in the current coordinate system).
Public propertyP2
The load magnitude vector at the end position. The values are given in the local coordinate system of the load (not in the current coordinate system).
Public propertyPosition1
The first input position point.
Public propertyPosition2
The second input position point.
Public propertyTorsion1
The first torsion.
Public propertyTorsion2
The second torsion.
Top
Methods
  NameDescription
Public methodDelete
Deletes the load line instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the load line into the model database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing load line in the model database to match the current one. At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a load line from the model database. The ID must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using System;

public class Example
{
       public void Example1()
       {
           LoadLine L = new LoadLine();
           L.P1 = new Vector(0000,0000,-1000);
           L.P2 = new Vector(0000,0000,-1000);
           L.DistanceA = 5;
           L.DistanceB = 6;
           L.Torsion1 = 1000;
           L.Torsion2 = 2000;
           L.Position1 = new Point(3000,12000,0);
           L.Position2 = new Point(4000,12000,0);
           L.LoadForm = LoadLine.LineLoadFormEnum.LOAD_FORM_LINE_1;

           L.AutomaticPrimaryAxisWeight = true;
           L.BoundingBoxDx = 500;
           L.BoundingBoxDy = 500;
           L.BoundingBoxDz = 500;
           L.LoadDispersionAngle = 5;
           L.PartFilter = "testing";
           L.PartNames = Load.LoadPartNamesEnum.LOAD_PART_NAMES_INCLUDE;
           L.PrimaryAxisDirection = new Vector(1000, 500, 0);
           L.Spanning = Load.LoadSpanningEnum.LOAD_SPANNING_SINGLE;
           L.Weight = 2;
           L.CreateFixedSupportConditionsAutomatically = true;

           if (!L.Insert())
               Console.WriteLine("LoadLine Insert failed!");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next