LoadLine Class

The LoadLine class defines a linearly-distributed force or torsion.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LoadLine : Load

The LoadLine type exposes the following members.

Constructors
  NameDescription
Public methodLoadLine
Creates a new load line instance.
Top
Properties
  NameDescription
Public propertyAutomaticPrimaryAxisWeight
The automatic primary axis weight.
(Inherited from Load.)
Public propertyBoundingBoxDx
The dimension of the bounding box in the X direction.
(Inherited from Load.)
Public propertyBoundingBoxDy
The dimension of the bounding box in the Y direction.
(Inherited from Load.)
Public propertyBoundingBoxDz
The dimension of the bounding box in the Z direction.
(Inherited from Load.)
Public propertyCreateFixedSupportConditionsAutomatically
Indicates whether fixed support conditions are created automatically.
(Inherited from Load.)
Public propertyDistanceA
The distance a (for shortening or dividing the length of a line load).
Public propertyDistanceB
The distance b (for shortening or dividing the length of a line load).
Public propertyFatherId
The identifier of the father object that the load is attached to.
(Inherited from Load.)
Public propertyGroup
The load group object for the load.
(Inherited from Load.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLoadAttachment
The load attachment.
(Inherited from Load.)
Public propertyLoadDispersionAngle
The load dispersion angle.
(Inherited from Load.)
Public propertyLoadForm
The load form.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyP1
The load magnitude vector at the start position. The values are given in the local coordinate system of the load (not in the current coordinate system).
Public propertyP2
The load magnitude vector at the end position. The values are given in the local coordinate system of the load (not in the current coordinate system).
Public propertyPartFilter
The part filter.
(Inherited from Load.)
Public propertyPartNames
The part names.
(Inherited from Load.)
Public propertyPosition1
The first input position point.
Public propertyPosition2
The second input position point.
Public propertyPrimaryAxisDirection
The vector for the primary axis direction.
(Inherited from Load.)
Public propertySpanning
The load spanning.
(Inherited from Load.)
Public propertyTorsion1
The first torsion.
Public propertyTorsion2
The second torsion.
Public propertyWeight
The weight.
(Inherited from Load.)
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the load line instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the load line into the model database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing load line in the model database to match the current one. At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a load line from the model database. The ID must be set.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using System;

public class Example
{
       public void Example1()
       {
           LoadLine L = new LoadLine();
           L.P1 = new Vector(0000,0000,-1000);
           L.P2 = new Vector(0000,0000,-1000);
           L.DistanceA = 5;
           L.DistanceB = 6;
           L.Torsion1 = 1000;
           L.Torsion2 = 2000;
           L.Position1 = new Point(3000,12000,0);
           L.Position2 = new Point(4000,12000,0);
           L.LoadForm = LoadLine.LineLoadFormEnum.LOAD_FORM_LINE_1;

           L.AutomaticPrimaryAxisWeight = true;
           L.BoundingBoxDx = 500;
           L.BoundingBoxDy = 500;
           L.BoundingBoxDz = 500;
           L.LoadDispersionAngle = 5;
           L.PartFilter = "testing";
           L.PartNames = Load.LoadPartNamesEnum.LOAD_PART_NAMES_INCLUDE;
           L.PrimaryAxisDirection = new Vector(1000, 500, 0);
           L.Spanning = Load.LoadSpanningEnum.LOAD_SPANNING_SINGLE;
           L.Weight = 2;
           L.CreateFixedSupportConditionsAutomatically = true;

           if (!L.Insert())
               Console.WriteLine("LoadLine Insert failed!");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next