GridCylindricalSurface Constructor

Creates a new grid plane instance.

The default values are as follows:

  • CylinderBase = new Arc(new Point(0, 0, 0), new Point(6000, 0, 0), new Vector(0, 0, 1), Math.PI);
  • CylinderHeight = 6000.0;
  • Label = "Default";
  • IsMagnetic = false;
  • ExtensionLeft = 2000.0;
  • ExtensionRight = 2000.0;
  • ExtensionBelow = 2000.0;
  • ExtensionAbove = 2000.0;
  • DrawingVisibility = false;

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public GridCylindricalSurface()
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next