WpfSaveLoad Class

Interaction logic for WpfSaveload.xaml
WpfSaveLoad
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class WpfSaveLoad : UserControl, 
	IComponentConnector

The WpfSaveLoad type exposes the following members.

Constructors
  NameDescription
Public methodWpfSaveLoad
Initializes a new instance of the WpfSaveLoad class with the default language and file extensions.
Top
Properties
  NameDescription
Public propertyHelpFileType
Gets or sets the help file type.
Public propertyCode exampleHelpKeyword
Gets or sets the HelpKeyword that the help file should be opened for. If you do not provide a HelpKeyword and HelpUrl is not set, the default start page for Tekla Structures Help viewer is displayed.
Public propertyHelpUrl
Gets or sets the HelpUrl where the help file is located. If you do not provide a HelpUrl, the Tekla Structures help viewer will be displayed with given HelpKeyword.
Public propertySaveAsText
Gets or sets the text in the SaveAs text box.
Public propertySaveLoadText
Gets the currently selected file name in the Save/Load combo box.
Public propertySelectedFileName
Gets or sets the text in the SaveAs text box.
Public propertyUserDefinedHelpFilePath
Gets or sets the file path where the UserDefined help file is located. If you do not provide a UserDefinedHelpFilePath, the general Help file, help.chm, will be displayed.
Top
Methods
  NameDescription
Public methodInitializeComponent
InitializeComponent
Top
Events
  NameDescription
Public eventAttributesLoadClicked
The AttributesLoadClicked event is triggered just after the load button has been clicked.
Public eventAttributesLoaded
The AttributesLoaded event is triggered just after attributes have been loaded into the dialog.
Public eventAttributesSaveClicked
The AttributesSaveClicked event is triggered just after the save button has been clicked.
Public eventAttributesSaved
The AttributesSaved event is triggered just after attributes are saved to a file.
Public eventHelpOpenClicked
The HelpOpenClicked event is triggered just after the help button has been clicked.
Public eventHelpOpened
The HelpOpened event is triggered just after the help file is opened.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next