ImageComboBox Class

Note: This API is now obsolete.

The ImageComboBox class represents a combo box control that can contain images.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
[ObsoleteAttribute("Use the new ImageListComboBox control.")]
public class ImageComboBox : UserControl

The ImageComboBox type exposes the following members.

Constructors
  NameDescription
Public methodImageComboBox
Initializes a new instance of the ImageComboBox class.
Top
Properties
  NameDescription
Public propertyDefaultValue
Gets or sets the default value in the image combo box.
Public propertyOptionList
Gets or sets the elements of the option list, the images that are in the image combo box.
Public propertySelectedIndex
Gets or sets the selected index of the image in the image combo box.
Public propertySelectedItem
Gets or sets the selected image in the image combo box.
Top
Events
  NameDescription
Public eventImageCBSelectedIndexChanged
The ImageCBSelectedIndexChanged event is triggered just after the selected index has been changed in the image combo box.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next