dotdiaUnitTypes_e Enumeration

Specifies the Tekla Structures unit types.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public enum dotdiaUnitTypes_e
Members
  Member nameValueDescription
INPUT_BOOLEAN-3The input boolean.
INPUT_INTEGER-2The input integer.
INPUT_STRING-1The input string.
INPUT_NONE0The input none.
INPUT_RATIO_UNIT1The input ratio unit.
INPUT_STRAIN_UNIT2The input strain unit.
INPUT_ANGLE_UNIT5The input angle unit.
OUTPUT_ANGLE_UNIT6The output angle unit.
INPUT_SECTION_ANGLE_UNIT7The input section angle unit.
INPUT_LENGTH_UNIT10The input length unit.
OUTPUT_LENGTH_UNIT11The output length unit.
INPUT_DEFORMATION_UNIT12The input deformation unit.
OUTPUT_DEFORMATION_UNIT13The output deformation unit.
INPUT_DIMENSION_UNIT14The input dimension unit.
INPUT_RADIUSOFINERTIA_UNIT16The input radius of inertia unit.
INPUT_AREA_UNIT20The input area unit.
OUTPUT_REINFAREA_UNIT21The output reinforced area unit.
OUTPUT_TRANSVREINF_UNIT22The output transverse reinforcement unit.
INPUT_AREAPERLENGTH_UNIT23The input area per length unit.
OUTPUT_VOLUME_UNIT30The output volume unit.
INPUT_SECTIONMODULUS_UNIT31The input section modulus unit.
INPUT_VOLUME_UNIT32The input volume unit.
INPUT_MOMENTOFINERTIA_UNIT40The input moment of inertia unit.
INPUT_TORSIONCONSTANT_UNIT41The input torsion constant unit.
INPUT_WARPINGCONSTANT_UNIT60The input warping constant unit.
INPUT_FORCE_UNIT100The input force unit.
OUTPUT_FORCE_UNIT101The output force unit.
INPUT_WEIGHT_UNIT102The input weight unit.
OUTPUT_WEIGHT_UNIT103The output weight unit.
INPUT_DISTRIBLOAD_UNIT110The input distributed load unit.
OUTPUT_DISTRIBLOAD_UNIT111The output distributed load unit.
INPUT_SPRINGCONSTANT_UNIT112The input spring constant unit.
OUTPUT_MASSPERLENGTH_UNIT113The output mass per length unit.
INPUT_SURFACELOAD_UNIT120The input surface load unit.
OUTPUT_SURFACELOAD_UNIT121The output surface load unit.
INPUT_STRENGTH_UNIT122The input strength unit.
OUTPUT_STRESS_UNIT123The output stress unit.
INPUT_MODULUS_UNIT124The input modulus unit.
INPUT_DENSITY_UNIT131The input density unit.
INPUT_MOMENT_UNIT200The input moment unit.
OUTPUT_MOMENT_UNIT201The output moment unit.
INPUT_DISTRIBMOMENT_UNIT205The input distributed moment unit.
INPUT_ROTSPRINGCONST_UNIT210The input rotation spring constant unit.
INPUT_TEMPERATURE_UNIT300The input temperature unit.
OUTPUT_TEMPERATURE_UNIT301The output temperature unit.
INPUT_THERMDILATCOEFF_UNIT310The input thermal dilatation coefficient unit.
INPUT_FACTOR_UNIT400The input factor unit.
INPUT_DATE_UNIT401The input date unit.
INPUT_DATE_TIME_MIN_UNIT402The input date time minutes unit.
INPUT_DATE_TIME_SEC_UNIT403The input date time seconds unit.
INPUT_LENGTH_FRACTIONAL_IMPERIAL1005The input length, fractional imperial.
INPUT_DEFORMATION_FRACTIONAL_IMPERIAL1305The input deformation, fractional imperial.
INPUT_DIMENSION_FRACTIONAL_IMPERIAL1405The input dimension, fractional imperial.
INPUT_RADIUSOFINERTIA_FRACTIONAL_IMPERIAL1605The input radius of inertia, fractional imperial.
OUTPUT_LENGTH_FRACTIONAL_IMPERIAL1105The output length, fractional imperial.
OUTPUT_DEFORMATION_FRACTIONAL_IMPERIAL1305The output deformation, fractional imperial.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next