InputObjectDependencyAttribute Class

The InputObjectDependencyAttribute class is used for storing an input object dependency which determines when the plug-in is updated in the system. The attribute is initialized from the custom attribute [InputObjectDependency(PluginBase.InputObjectDependency Type)] in the plug-in source.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsInputObjectDependencyAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class InputObjectDependencyAttribute : Attribute

The InputObjectDependencyAttribute type exposes the following members.

Constructors
  NameDescription
Public methodInputObjectDependencyAttribute(Int32)
The custom attribute [InputObjectDependency(PluginBase.InputObjectDependency Type)] uses this to store a dependency attribute which determines when the plug-in is updated in the system. This is not to be used by itself.
Public methodInputObjectDependencyAttribute(PluginBaseInputObjectDependency)
The custom attribute [InputObjectDependency(PluginBase.InputObjectDependency Type)] uses this to store a dependency attribute which determines when the plug-in is updated in the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
Returns the type of the input object dependency.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next