TextTextAttributes Class

The TextAttributes class is the attributes class for the text.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingTextTextAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class TextAttributes : AttributesBase, 
	IPreferredPlacing

The TextTextAttributes type exposes the following members.

Constructors
  NameDescription
Public methodTextTextAttributes
Creates a new default text attributes instance that loads standard attributes.
Public methodTextTextAttributes(String)
Creates a new text attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyAlignment
The text object's alignment (left, center, right).
Public propertyAngle
The angle of the text frame.
Public propertyArrowHead
The arrowhead of the leader line.
Public propertyCustomPresentation
Custom presentation GUID to be applied to the object type
Public propertyFont
The text object's font settings.
Public propertyFrame
The frame for the text.
Public propertyPlacingAttributes
The placing attributes that the object should use. Using these you can specify whether the object is automatically arranged in the drawing or not.
Public propertyPreferredPlacing
The type of placing the object should use. See the preferred placing types for different types of placing.
Public propertyRulerWidth
Gets or sets the width in paper coordinates of the ruler to be used in word wrapping.
Public propertyTransparentBackground
Gets or sets a value indicating whether the background transparency is enabled for texts.
Public propertyUseWordWrapping
Gets or sets a value indicating whether to [use word wrapping].
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next