LoadTemperature Class

The LoadTemperature class defines a temperature change in a part, or a temperature difference between two part surfaces.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LoadTemperature : Load

The LoadTemperature type exposes the following members.

Constructors
  NameDescription
Public methodLoadTemperature
Initializes a new instance of the LoadTemperature class.
Top
Properties
  NameDescription
Public propertyAutomaticPrimaryAxisWeight Obsolete.
Property not supported in LoadTemperature class.
Public propertyCreateFixedSupportConditionsAutomatically Obsolete.
Property not supported in LoadTemperature class.
Public propertyInitialAxialElongation
Gets or sets the initial axial elongation.
Public propertyLoadDispersionAngle Obsolete.
Property not supported in LoadTemperature class.
Public propertyPosition1
Gets or sets the first input position point.
Public propertyPosition2
Gets or sets the second input position point.
Public propertyPrimaryAxisDirection Obsolete.
Property not supported in LoadTemperature class.
Public propertySpanning Obsolete.
Property not supported in LoadTemperature class.
Public propertyTemperatureChangeForAxialElongation
Gets or sets the temperature change for axial elongation.
Public propertyTemperatureDifferentialSideToSide
Gets or sets the temperature differential from side to side.
Public propertyTemperatureDifferentialTopToBottom
Gets or sets the temperature differential from top to bottom.
Public propertyWeight Obsolete.
Property not supported in LoadTemperature class.
Top
Methods
  NameDescription
Public methodDelete
Deletes the load temperature instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the load temperature into the model database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing load temperature in the model database to match the current one. At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a load temperature from the model database. The ID must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using System;
using Tekla.Structures.Geometry3d;
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           LoadTemperature temperatureLoad = new LoadTemperature();
           temperatureLoad.Position1 = new Point(0, 0, 0);
           temperatureLoad.Position2 = new Point(1000, 0, 0);
           temperatureLoad.BoundingBoxDx = 500;
           temperatureLoad.BoundingBoxDy = 500;
           temperatureLoad.BoundingBoxDz = 500;
           temperatureLoad.PartNames = Load.LoadPartNamesEnum.LOAD_PART_NAMES_INCLUDE;
           temperatureLoad.PartFilter = "example";
           temperatureLoad.TemperatureChangeForAxialElongation = 1.0;
           temperatureLoad.TemperatureDifferentialSideToSide = 2.0;
           temperatureLoad.TemperatureDifferentialTopToBottom = 3.0;
           temperatureLoad.InitialAxialElongation = 4.0;

           if (!temperatureLoad.Insert())
           {
               Console.WriteLine("Temperature load insert failed!");
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next