LoadTemperature Class

The LoadTemperature class defines a temperature change in a part, or a temperature difference between two part surfaces.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LoadTemperature : Load

The LoadTemperature type exposes the following members.

Constructors
  NameDescription
Public methodLoadTemperature
Initializes a new instance of the LoadTemperature class.
Top
Properties
  NameDescription
Public propertyAutomaticPrimaryAxisWeight Obsolete.
Property not supported in LoadTemperature class.
Public propertyBoundingBoxDx
The dimension of the bounding box in the X direction.
(Inherited from Load.)
Public propertyBoundingBoxDy
The dimension of the bounding box in the Y direction.
(Inherited from Load.)
Public propertyBoundingBoxDz
The dimension of the bounding box in the Z direction.
(Inherited from Load.)
Public propertyCreateFixedSupportConditionsAutomatically Obsolete.
Property not supported in LoadTemperature class.
Public propertyFatherId
The identifier of the father object that the load is attached to.
(Inherited from Load.)
Public propertyGroup
The load group object for the load.
(Inherited from Load.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyInitialAxialElongation
Gets or sets the initial axial elongation.
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLoadAttachment
The load attachment.
(Inherited from Load.)
Public propertyLoadDispersionAngle Obsolete.
Property not supported in LoadTemperature class.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyPartFilter
The part filter.
(Inherited from Load.)
Public propertyPartNames
The part names.
(Inherited from Load.)
Public propertyPosition1
Gets or sets the first input position point.
Public propertyPosition2
Gets or sets the second input position point.
Public propertyPrimaryAxisDirection Obsolete.
Property not supported in LoadTemperature class.
Public propertySpanning Obsolete.
Property not supported in LoadTemperature class.
Public propertyTemperatureChangeForAxialElongation
Gets or sets the temperature change for axial elongation.
Public propertyTemperatureDifferentialSideToSide
Gets or sets the temperature differential from side to side.
Public propertyTemperatureDifferentialTopToBottom
Gets or sets the temperature differential from top to bottom.
Public propertyWeight Obsolete.
Property not supported in LoadTemperature class.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the load temperature instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the load temperature into the model database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing load temperature in the model database to match the current one. At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a load temperature from the model database. The ID must be set.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using System;
using Tekla.Structures.Geometry3d;
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           LoadTemperature temperatureLoad = new LoadTemperature();
           temperatureLoad.Position1 = new Point(0, 0, 0);
           temperatureLoad.Position2 = new Point(1000, 0, 0);
           temperatureLoad.BoundingBoxDx = 500;
           temperatureLoad.BoundingBoxDy = 500;
           temperatureLoad.BoundingBoxDz = 500;
           temperatureLoad.PartNames = Load.LoadPartNamesEnum.LOAD_PART_NAMES_INCLUDE;
           temperatureLoad.PartFilter = "example";
           temperatureLoad.TemperatureChangeForAxialElongation = 1.0;
           temperatureLoad.TemperatureDifferentialSideToSide = 2.0;
           temperatureLoad.TemperatureDifferentialTopToBottom = 3.0;
           temperatureLoad.InitialAxialElongation = 4.0;

           if (!temperatureLoad.Insert())
           {
               Console.WriteLine("Temperature load insert failed!");
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next