Component Class

The Component class represents a component. A component is a modelling tool that typically assembles multiple parts to build some type of a structure, for example a hall macro or at a smaller scale a reinforcement component (a macro). Also, a custom part is a component.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Component : BaseComponent, 
	IAssemblable

The Component type exposes the following members.

Constructors
  NameDescription
Public methodComponent
Creates a new component instance.
Public methodComponent(ComponentInput)
Creates a new component instance with the given component input.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Public methodDelete
Deletes the component instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodGetAssembly
Returns the assembly that the component belongs to.
Public methodGetBooleans
Returns an enumerator of all the connected boolean objects.
Public methodGetComponentInput
Returns the component input object.
Public methodGetComponents
Returns an enumerator of all the connected components.
Public methodInsert
Inserts the component into the model database. The component input needs to be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing component in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a component from the model database. The component ID must be set.
(Overrides ModelObjectSelect.)
Public methodSetComponentInput
Sets the component input object for the component. The component input object contains all the input objects and positions that are needed for the component creation.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using System;

public class Example
{
       public void Example1()
       {
           Beam B = new Beam(new Point(12000, 0, 0), new Point(12000, 0, 6000));
           B.Profile.ProfileString = "380*380";
           B.Material.MaterialString = "K40-1";
           if (B.Insert())
           {
               Component C = new Component();
               C.Name = "Component Test";
               C.Number = 30000063;

               ComponentInput CI = new ComponentInput();
               CI.AddInputObject(B);

               C.SetComponentInput(CI);

               C.LoadAttributesFromFile("standard");

               C.SetAttribute("side_bar_space", 333.0);

               if (!C.Insert())
               {
                   Console.WriteLine("Component Insert failed");
               }
               else
               {
                   Console.WriteLine(C.Identifier.ID);

                   Double DValue = 0.0;
                   if (!C.GetAttribute("side_bar_space", ref DValue) || DValue != 333)
                       Console.WriteLine("Component GetAttribute failed");
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next