AutoDirectionTypeAttribute Class

The AutoDirectionTypeAttribute class is used for storing the auto direction type. Based on the type the system will then calculate the up direction of the connection/detail if the "Auto" up direction is chosen in the dialog. The attribute is initialized from the custom attribute [AutoDirectionType(AutoDirectionTypeEnum.AUTODIR_DETAIL)] in the connection/detail source.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsAutoDirectionTypeAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class AutoDirectionTypeAttribute : Attribute

The AutoDirectionTypeAttribute type exposes the following members.

Constructors
  NameDescription
Public methodAutoDirectionTypeAttribute(Int32)
The custom attribute [AutoDirectionType()] uses this to store the auto direction type to the system. This is not to be used by itself.
Public methodAutoDirectionTypeAttribute(AutoDirectionTypeEnum)
The custom attribute [AutoDirectionType()] uses this to store the auto direction type to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
The custom attribute [AutoDirectionType()] uses this to store the auto direction type to the system. This is not to be used by itself.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next