WeldWeldAttributes Class

The WeldAttributes class is the attributes class for the weld.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingWeldWeldAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class WeldAttributes : AttributesBase

The WeldWeldAttributes type exposes the following members.

Constructors
  NameDescription
Public methodWeldWeldAttributes
Creates a new default weld attributes instance that loads standard attributes.
Public methodWeldWeldAttributes(String)
Creates a new weld attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyCustomPresentation
Custom presentation GUID to be applied to the weld
Public propertyDrawHiddenLines
True if hidden lines are drawn.
Public propertyDrawOwnHiddenLines
True if own hidden lines are drawn.
Public propertyHiddenLines
The line type of hidden lines.
Public propertyRepresentation
The representation of the weld.
Public propertyVisibleLines
The line type of visible lines.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next