ClipPlaneCollection Class

The ClipPlaneCollection class handles the collection of the clip planes.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.UIClipPlaneCollection

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ClipPlaneCollection : ICollection, 
	IEnumerable

The ClipPlaneCollection type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of elements contained in the ICollection.
Public propertyIsSynchronized
Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public propertySyncRoot
Gets an object that can be used to synchronize access to the ICollection.
Top
Methods
  NameDescription
Public methodCopyTo
Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public methodGetEnumerator
Returns an enumerator that iterates through a collection.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next