ReferenceModelObjectAttribute Class

The ReferenceModelObjectAttribute class is a base class from where concrete attributes are derived from. The documentation about different attributes and their function can be found from the vendor specification, for example from the IFC format specification.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    More...

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class ReferenceModelObjectAttribute

The ReferenceModelObjectAttribute type exposes the following members.

Properties
  NameDescription
Public propertyDescription
The description of the product.
Public propertyExtrusion
The extrusion vector.
Public propertyName
The name of the product.
Public propertyObjectType
The object type of the product.
Public propertyOrigin
The origin of the extrusion.
Public propertyProfileName
The name of the profile (often empty).
Public propertyxDir
The X-axis direction.
Top
See Also
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CircleHollowProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CircleProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CShapeProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_EllipseProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_IShapeProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_LShapeProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleHollowProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_TShapeProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_UShapeProfile
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_ZShapeProfile
    Tekla.Structures.Model.CollaborationParametricObject_CustomProfile
    Tekla.Structures.Model.CollaborationParametricObject_ObjectBoundingBox
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next