PolyLine Class

The PolyLine class represents a line that consists of one or more line segments. To create a polyline, you have to give a list of the points that will form the polyline. The first point in the list will be connected with the second point in the list, the second point in the list will be connected with the third point in the list, etc.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dPolyLine

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class PolyLine

The PolyLine type exposes the following members.

Constructors
  NameDescription
Public methodPolyLine
Instantiates a polyline with the given Points.
Top
Properties
  NameDescription
Public propertyPoints
The points the polyline consists of.
Top
Methods
  NameDescription
Public methodEquals
Returns true if the objects are equal.
(Overrides ObjectEquals(Object).)
Public methodGetHashCode
Returns a hash code for a polyline. Notice, in extremely rare cases, you might not get the same hash code for two polylines even though they are considered equal! This should, however, happen only in extremely rare cases!
(Overrides ObjectGetHashCode.)
Public methodLength
Returns the length of a polyline.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Checks the equality of two polylines.
Public operatorStatic memberInequality
Checks the inequality of two polylines.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next