Detail Class

The Detail class represents a detail. A detail is different from a connection since the detail only connects to one part.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Detail : BaseComponent

The Detail type exposes the following members.

Constructors
  NameDescription
Public methodDetail
Creates a new detail instance.
Top
Properties
  NameDescription
Public propertyAutoDirectionType
The auto direction type. Default value is AUTODIR_DETAIL. Value should be AUTODIR_NA to set direction with UpVector property. Value should be AUTODIR_FROM_ATTRIBUTE_FILE to set direction with detail attribute file.
Public propertyClass
The class of the detail.
Public propertyCode
The code of the detail. The code can be used to classify the detail. The code can be reported and shown in drawings. The maximum length of the string is 20 characters.
Public propertyDetailType
The detail type.
Public propertyPositionType
The position type.
Public propertyStatus
The read only status of the detail. The status can be reported and shown in drawings. The color of the detail symbol in the model indicates the status of the detail.
Public propertyUpVector
A vector indicating which direction is considered the up direction.
Top
Methods
  NameDescription
Public methodDelete
Deletes the detail instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodGetPrimaryObject
Returns the primary object.
Public methodGetReferencePoint
Returns the reference point.
Public methodInsert
Inserts the detail into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing detail in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a detail from the model database. The detail ID must be set.
(Overrides ModelObjectSelect.)
Public methodSetPrimaryObject
Sets the detail's primary object.
Public methodSetReferencePoint
Sets the reference point; the point the user would pick for the detail to appear to.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using Tekla.Structures;
using System;

public class Example
{
       public void Example1()
       {
           Beam B = new Beam(new Point(13000,3000,-500), new Point(13000,3000,6000));
           B.Profile.ProfileString = "HEA400";
           B.Material.MaterialString = "S235JR";

           if(B.Insert())
           {
               Detail D = new Detail();
               D.Name = "Test End Plate Detail";
               D.Number = 1002;
               D.LoadAttributesFromFile("standard");
               D.UpVector = new Vector(0,0,0);
               D.PositionType = PositionTypeEnum.MIDDLE_PLANE;
               D.AutoDirectionType = AutoDirectionTypeEnum.AUTODIR_DETAIL;
               D.DetailType = DetailTypeEnum.END;

               D.SetPrimaryObject(B);
               D.SetReferencePoint(new Point(13000,3000,3000));

               D.SetAttribute("el", 33.0);
               D.SetAttribute("er", 33.0);

               if(!D.Insert())
               {
                   Console.WriteLine("Detail Insert failed");
               }
               else
               {
                   Console.WriteLine(D.Identifier.ID);

                   Double DValue = 0.0;
                   if(!D.GetAttribute("er", ref DValue) || DValue != 33)
                       Console.WriteLine("Detail GetAttribute failed");
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next